Subject: pgAdmin 4 commit: Ignore config_local.py and config_distro.py when runn

From: Dave Page <[email-masked]>
Date: Thu, 15 Mar 2018 11:10:05 +0000

Ignore config_local.py and config_distro.py when running PEP-8 checks.

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=53ae960aeba0dde6109b91c171f22758b1b04ebe

Modified Files
--------------
web/.pycodestyle | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

---

From: Ashesh Vashi <[email-masked]>
Date: Thu, 15 Mar 2018 16:44:22 +0530

Hi,

I have just noticed, we're ignoring migrations directory too.
Should we not also check code styling for migrations directory?

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Mar 2018 07:23:39 -0400

Hi

On Thu, Mar 15, 2018 at 7:14 AM, Ashesh Vashi <[email-masked]
> wrote:

> Should we not also check code styling for migrations directory?

Yeah, I was going to ask about that :-). Is there a specific reason why
we're ignoring the migrations Murtuza?

>> https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdif
>> f;h=53ae960aeba0dde6109b91c171f22758b1b04ebe
>>
>> Modified Files
>> --------------
>> web/.pycodestyle | 2 +-

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 15 Mar 2018 18:00:07 +0530

On Thu, Mar 15, 2018 at 4:53 PM, Dave Page <[email-masked]> wrote:

> Hi
>
> On Thu, Mar 15, 2018 at 7:14 AM, Ashesh Vashi <
> [email-masked]> wrote:
>
>> Hi,
>>
​To ease writing long SQL's.

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Mar 2018 12:12:58 -0400

> ​To ease writing long SQL's.

Perhaps we could just skip the long line check for those files?

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 15 Mar 2018 21:55:22 +0530

Hi Dave,

On Thu, Mar 15, 2018 at 9:42 PM, Dave Page <[email-masked]> wrote:

>
>
> On Thu, Mar 15, 2018 at 8:30 AM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
​We have to create separate config for that and then run pycodestyle using
that config for migration.​

​1) pycodestyle --config=.pycodestyle
​2) pycodestyle --config=.pycodestyle_migration

something like that, Because I checked the documentation and I didn't find
any option to have single config file for individual directories.

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Mar 2018 15:31:56 -0400

> any option to have single config file for individual directories.

Urgh. I suppose we could keep a config file in the migration directory, but
even then, we'll get two sets of stats out for running two tests.

---

From: Joao De Almeida Pereira <[email-masked]>
Date: Fri, 16 Mar 2018 11:40:06 +0000

Hello,
Personally I believe we should fix the config_local pep issues and just
ignore the migrations. Specially because the migration file should not have
a lot of python code.

Thanks

On Thu, Mar 15, 2018 at 3:32 PM Dave Page <[email-masked]> wrote:

>>>>> Yeah, I was going to ask about that :-). Is there a specific reason
>>>>> why we're ignoring the migrations Murtuza?
>>>>>
>> ​We have to create separate config for that and then run pycodestyle
>> using that config for migration.​
>>
>> something like that, Because I checked the documentation and I didn't
>> find any option to have single config file for individual directories.
>>
>
> Urgh. I suppose we could keep a config file in the migration directory,
> but even then, we'll get two sets of stats out for running two tests.
>
>
>>
>>
>>>
>>>>
>>>>>
>>>>>>
>>>>>> --
>>>>>>
>>>>>> Thanks & Regards,
>>>>>>
>>>>>> Ashesh Vashi

---

From: Dave Page <[email-masked]>
Date: Fri, 16 Mar 2018 07:59:48 -0400

Well config_local isn't part of the source tree, so it's easier to just
ignore that. I'm happy with ignoring the migrations as well.

On Friday, March 16, 2018, Joao De Almeida Pereira <
[email-masked]> wrote:

>> On Thu, Mar 15, 2018 at 12:25 PM, Murtuza Zabuawala <murtuza.zabuawala@
>> enterprisedb.com> wrote:
>>
>>> Hi Dave,
>>>