Subject: [pgAdmin4][RM3679] Query Tool not working

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 3 Jan 2019 13:06:49 +0530

Hi Hackers,

This is related to a very difficult to reproduce issue where query tool
opens blank. Note the disconnected icon, not to be confused with another
issue where resizing the query tool works and icon is connected.
Somehow, this occurred on my system (screenshot attached). It turned out to
be a webpack issue and many users are facing this (in other projects).
A workaround suggested by
https://github.com/webpack/webpack/issues/6094#issuecomment-413178158 is
applied in the attached patch.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Dave Page <[email-masked]>
Date: Thu, 3 Jan 2019 14:44:03 +0000

Thanks, applied.

On Thu, Jan 3, 2019 at 7:37 AM Aditya Toshniwal
<[email-masked]> wrote:
>
> Hi Hackers,
>
> This is related to a very difficult to reproduce issue where query tool opens blank. Note the disconnected icon, not to be confused with another issue where resizing the query tool works and icon is connected.
> Somehow, this occurred on my system (screenshot attached). It turned out to be a webpack issue and many users are facing this (in other projects).
> A workaround suggested by https://github.com/webpack/webpack/issues/6094#issuecomment-413178158 is applied in the attached patch.
>
> Kindly review.
>
> --
> Thanks and Regards,
> Aditya Toshniwal

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company