Subject: [pgAdmin4][Patch]: RM 4428 and 4448

From: Akshay Joshi <[email-masked]>
Date: Mon, 15 Jul 2019 18:02:03 +0530

Hi Hackers,

Attached is the patch to fix following issues in pgagent module:

   - RM 4428 "malformed array literal error when updating pgagent job".
   - RM 4448 "Error when updating connection string in pgagent Jobs."
   - When user create a schedule using Create->Schedule dialog browser tree
   is not showing newly created node.
   - Properties tab showing same properties for all the created schedule.
   - Added validation in "pga_jobstep.js", throws error on browser when we
   modify step from the pgagent dialog and select the same node.

Added regression test cases to add schedule and step from the pgagent job
itself.
Please review it.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Mon, 15 Jul 2019 15:55:06 +0100

Thanks, applied.

On Mon, Jul 15, 2019 at 1:32 PM Akshay Joshi <[email-masked]>
wrote:

>    - When user create a schedule using Create->Schedule dialog browser
>    tree is not showing newly created node.
>    - Added validation in "pga_jobstep.js", throws error on browser when
>    we modify step from the pgagent dialog and select the same node.
>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company