Subject: [pgAdmin][RM2653] Lock layout

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 30 May 2019 15:44:55 +0530

Hi Hackers,

Attached is the patch to introduce feature to lock the layout with three
different levels:
1) None - No locking
2) Prevent docking - The docking/undocking of panels will be disabled
3) Full lock - The resizing along with docking/undocking of panels will be
disabled

- This can be changed from new menu under File->Lock layout-><The level> or
from Preferences->Browser->Display->Lock Layout
- JS test cases added.

With this patch I have also changed below:
1) Moved the maintenance dialog button group control to new common control
named RadioModern, which I have re-used in preferences for lock layout
levels.
2) Added main nav bar menu with check feature, the menus which can checked.
3) Ability to add submenus from existing get_own_menuitems in python code
which is not possible currently.
3) Separated all the layout related functions from browser.js to new file
layout.js to help JS testing.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Thu, 30 May 2019 15:12:28 -0400

Hi

Can you rebase please?

(pgadmin4) dpage@orac:*~/git/pgadmin4*$ git apply ~/Downloads/RM2653.patch

error: patch failed: web/pgadmin/browser/static/js/browser.js:15

error: web/pgadmin/browser/static/js/browser.js: patch does not apply

On Thu, May 30, 2019 at 6:15 AM Aditya Toshniwal <
[email-masked]> wrote:

> - This can be changed from new menu under File->Lock layout-><The level>
> or from Preferences->Browser->Display->Lock Layout
> - JS test cases added.
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 31 May 2019 10:36:47 +0530

Hi,

Attached is the updated rebased patch.
I realised I didn't update the documentations. The patch also include doc
updates.

On Fri, May 31, 2019 at 12:42 AM Dave Page <[email-masked]> wrote:

>> 3) Full lock - The resizing along with docking/undocking of panels will
>> be disabled
>>
>> 1) Moved the maintenance dialog button group control to new common
>> control named RadioModern, which I have re-used in preferences for lock
>> layout levels.

---

From: Dave Page <[email-masked]>
Date: Fri, 31 May 2019 11:51:56 -0400

Thanks, patch applied.

On Fri, May 31, 2019 at 1:07 AM Aditya Toshniwal <
[email-masked]> wrote:

>>> 3) Ability to add submenus from existing get_own_menuitems in python
>>> code which is not possible currently.
>>> 3) Separated all the layout related functions from browser.js to new
>>> file layout.js to help JS testing.
>>>
>>> Kindly review.
>>>
>>> --
>>> Thanks and Regards,
>>> Aditya Toshniwal