Subject: PATCH: Python2.6 compatibility fixes (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 6 Sep 2016 16:36:12 +0530

Hi,

PFA minor patch for Python2.6 compatibility with pgAdmin4.
Please review.

Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 6 Sep 2016 16:38:12 +0530

+++ Adding related RM.

RM#1636 & RM#1659

---

From: Dave Page <[email-masked]>
Date: Tue, 6 Sep 2016 14:22:35 +0100

Thanks, patch applied.

On Tue, Sep 6, 2016 at 12:08 PM, Murtuza Zabuawala
<[email-masked]> wrote:
> On Tue, Sep 6, 2016 at 4:36 PM, Murtuza Zabuawala
> <[email-masked]> wrote:
>>
>> Hi,
>>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Fri, 9 Sep 2016 18:23:34 +0530

*Please find attached patch with following fix:*

1) While running pgAdmin4 with latest git pull on Windows x64 environment,
I got an exception on terminal console,

> NameError
> NameError: global name 'arch_keys' is not defined​

*​Issue:​* arch_keys was defined inside the method add_server, but used
outside the method.

I have handled this issue in attached patch.

---

From: Dave Page <[email-masked]>
Date: Fri, 9 Sep 2016 14:51:36 +0100

Thanks, applied.

On Fri, Sep 9, 2016 at 1:53 PM, Surinder Kumar
<[email-masked]> wrote:
> Please find attached patch with following fix:
>
> 1) While running pgAdmin4 with latest git pull on Windows x64 environment, I
> got an exception on terminal console,
>>
>> NameError
>> NameError: global name 'arch_keys' is not defined
>
>
> Issue: arch_keys was defined inside the method add_server, but used outside
> the method.
>