Subject: [pgAdmin4][patch]: Fix for RM 1320

From: Neel Patel <[email-masked]>
Date: Mon, 25 Jul 2016 11:02:02 +0530

Hi,

Please find attached patch file for the fix of RM- 1320.

RM-1320 - Unable to create foreign data wrapper when user change the schema
of extension 'postgres_fdw_handler'.

Thanks,
Neel Patel

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Neel Patel <[email-masked]>
Date: Mon, 25 Jul 2016 11:31:53 +0530

Adding more details.

*Root cause:-*

When user change schema of already created fdw extension then while
creating the new fdw we should append the <schema_name>.<fdw_handler_name>.
Previously we added only <fdw_handler_name> so while executing the query it
will not be able to find fdw handler name without schema name.

e.g. If user changed the fdw handler 'postgres_fdw_handler' under schema
'test' then we should display the handler  name under fdw as "test.
 postgres_fdw_handler".

*Solution:-*

With this patch, we have added <schema_name>.<fdw_handler_name> so while
creating or updating the fdw, proper sql will be generated.

Thanks,
Neel Patel

On Mon, Jul 25, 2016 at 11:02 AM, Neel Patel <[email-masked]>
wrote:

> RM-1320 - Unable to create foreign data wrapper when user change the
> schema of extension 'postgres_fdw_handler'.
>
> Thanks,
> Neel Patel
>

---

From: Dave Page <[email-masked]>
Date: Mon, 25 Jul 2016 12:48:24 +0100

Thanks - applied.

On Mon, Jul 25, 2016 at 7:01 AM, Neel Patel <[email-masked]> wrote:
> Adding more details.
>
> Root cause:-
>
> When user change schema of already created fdw extension then while creating
> the new fdw we should append the <schema_name>.<fdw_handler_name>.
> Solution:-

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company