Subject: pgAdmin 4 v3.1 Released

From: Dave Page <[email-masked]>
Date: Thu, 28 Jun 2018 10:56:15 +0100

The pgAdmin Development Team are pleased to announce pgAdmin 4 version 3.1.
This release of pgAdmin 4 includes over 30 bug fixes and new features. For
more details please see the release notes at:

    https://www.pgadmin.org/docs/pgadmin4/dev/release_notes_3_1.html.

pgAdmin is the leading Open Source graphical management tool for
PostgreSQL. For more information, please see:

    https://www.pgadmin.org/

Notable changes in this release include:

* Add support for SSH tunneled connections.
* Various fixes for handling data in SQL_ASCII databases.
* Add support for LISTEN/NOTIFY in the Query Tool.
* Function/Procedure support for PostgreSQL 11.
* Various fixes and enhancements to the Greenplum support.

Builds for Windows and macOS are available now, along with a Python Wheel,
Docker Container and source code tarball from:

    https://www.pgadmin.org/download/

RPM and DEB packages are expected to be available on the postgresql.org
repositories within the next few days.

-- 
Dave Page
pgAdmin Project Lead

---

From: Isaias Sanchez <[email-masked]>
Date: Thu, 28 Jun 2018 10:43:06 +0000

I just installed the Python Wheel 3.1 version on a centos 6 server and 
the app doesn't start, the error is this:

2018-06-28 10:37:23,668: ERROR  werkzeug:       Error on request:
Traceback (most recent call last):
   File "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py", 
line 177, in run_wsgi
     execute(self.server.app)
   File "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py", 
line 165, in execute
     application_iter = app(environ, start_response)
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1997, in __call__
     return self.wsgi_app(environ, start_response)
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1985, in wsgi_app
     response = self.handle_exception(e)
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1540, in handle_exception
     reraise(exc_type, exc_value, tb)
   File "/usr/local/lib/python3.6/site-packages/flask/_compat.py", line 
33, in reraise
     raise value
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1982, in wsgi_app
     response = self.full_dispatch_request()
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1615, in full_dispatch_request
     return self.finalize_request(rv)
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1632, in finalize_request
     response = self.process_response(response)
   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 
1856, in process_response
     response = handler(response)
   File "/usr/local/lib/python3.6/site-packages/flask_htmlmin.py", line 
35, in response_minify
     self.html_minify.minify(response.get_data(as_text=True))
   File "/usr/local/lib/python3.6/site-packages/htmlmin/main.py", line 
152, in minify
     self.input(*input)
   File "/usr/local/lib/python3.6/site-packages/htmlmin/main.py", line 
164, in input
     self._parser.feed(i)
   File "/usr/local/lib/python3.6/html/parser.py", line 111, in feed
     self.goahead(0)
   File "/usr/local/lib/python3.6/html/parser.py", line 171, in goahead
     k = self.parse_starttag(i)
   File "/usr/local/lib/python3.6/html/parser.py", line 345, in 
parse_starttag
     self.handle_starttag(tag, attrs)
   File "/usr/local/lib/python3.6/site-packages/htmlmin/parser.py", line 
222, in handle_starttag
     self._in_pre_tag -= self._close_tags_up_to(in_tag[0])
   File "/usr/local/lib/python3.6/site-packages/htmlmin/parser.py", line 
189, in _close_tags_up_to
     raise OpenTagNotFoundError()
htmlmin.parser.OpenTagNotFoundError

On 28/06/18 09:56, Dave Page wrote:
> The pgAdmin Development Team are pleased to announce pgAdmin 4 version 
> 3.1. This release of pgAdmin 4 includes over 30 bug fixes and new 
> features. For more details please see the release notes at:
>
> Builds for Windows and macOS are available now, along with a Python 
> Wheel, Docker Container and source code tarball from:
>
> RPM and DEB packages are expected to be available on the 
> postgresql.org <http://postgresql.org> repositories within the next 
> few days.
>
> -- 
> Dave Page
> pgAdmin Project Lead
>

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 28 Jun 2018 16:18:36 +0530

Can you please provide the output of  the below command?

pip freeze

On Thu, Jun 28, 2018 at 4:13 PM, Isaias Sanchez <[email-masked]>
wrote:

> I just installed the Python Wheel 3.1 version on a centos 6 server and the
> app doesn't start, the error is this:
>
>   File "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py", line
> 177, in run_wsgi
>     execute(self.server.app)
>   File "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py", line
> 165, in execute
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1997,
> in __call__
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1985,
> in wsgi_app
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1540,
> in handle_exception
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1982,
> in wsgi_app
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1615,
> in full_dispatch_request
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1632,
> in finalize_request
>   File "/usr/local/lib/python3.6/site-packages/flask/app.py", line 1856,
> in process_response
> 3.1. This release of pgAdmin 4 includes over 30 bug fixes and new features.
> For more details please see the release notes at:
>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 28 Jun 2018 16:22:01 +0530

Looks like you have an older version of htmlmin module (< 0.1.12).

Please install/update htmlmin to version 0.1.12, let us know if that solves
the issue.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Isaias Sanchez <[email-masked]>
Date: Thu, 28 Jun 2018 11:05:58 +0000

This help a bit, I can log in, but the web is like only text, probably 
is necessary to update another:

# pip3 freeze
alembic==0.9.2
asn1crypto==0.24.0
Babel==2.3.4
bcrypt==3.1.4
beautifulsoup4==4.4.1
blinker==1.4
cffi==1.11.5
click==6.6
cryptography==2.2.2
extras==1.0.0
fixtures==3.0.0
Flask==0.12.2
Flask-Babel==0.11.1
Flask-BabelEx==0.9.3
Flask-Gravatar==0.5.0
Flask-HTMLmin==1.3.2
Flask-Login==0.3.2
Flask-Mail==0.9.1
Flask-Migrate==2.1.1
Flask-Paranoid==0.2.0
Flask-Principal==0.4.0
Flask-Script==2.0.5
Flask-Security==3.0.0
Flask-SQLAlchemy==2.3.2
Flask-WTF==0.14.2
html5lib==1.0.1
htmlmin==0.1.12
idna==2.7
itsdangerous==0.24
Jinja2==2.7.3
linecache2==1.0.0
Mako==1.0.6
MarkupSafe==0.23
paramiko==2.4.1
passlib==1.7.1
pbr==3.1.1
pgadmin4==3.1
psycopg2==2.7.5
psycopg2-binary==2.7.5
pyasn1==0.4.3
pycparser==2.18
pycrypto==2.6.1
PyNaCl==1.2.1
pyrsistent==0.14.2
python-dateutil==2.7.2
python-editor==1.0.3
python-mimeparse==1.6.0
pytz==2018.3
simplejson==3.13.2
six==1.11.0
speaklater==1.3
SQLAlchemy==1.2.6
sqlparse==0.2.4
sshtunnel==0.1.4
testtools==2.3.0
traceback2==1.4.0
unittest2==1.1.0
webencodings==0.5.1
Werkzeug==0.9.6
WTForms==2.1

On 28/06/18 10:52, Murtuza Zabuawala wrote:
> Please install/update htmlmin to version 0.1.12, let us know if that 
> solves the issue.
>
> -- 
> Regards,
> Murtuza Zabuawala
> EnterpriseDB: http://www.enterprisedb.com <http://www.enterprisedb.com/>
> On Thu, Jun 28, 2018 at 4:13 PM, Isaias Sanchez 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I just installed the Python Wheel 3.1 version on a centos 6 server
>     and the app doesn't start, the error is this:
>
>       File
>     "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py", line
>     177, in run_wsgi
>         execute(self.server.app)
>       File
>     "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py", line
>     165, in execute
>       File "/usr/local/lib/python3.6/site-packages/flask/_compat.py",
>     line 33, in reraise
>         raise value
>       File "/usr/local/lib/python3.6/site-packages/flask_htmlmin.py",
>     line 35, in response_minify
>       File "/usr/local/lib/python3.6/site-packages/htmlmin/main.py",
>     line 152, in minify
>         self.input(*input)
>       File "/usr/local/lib/python3.6/site-packages/htmlmin/main.py",
>     line 164, in input
>         self._parser.feed(i)
>       File "/usr/local/lib/python3.6/site-packages/htmlmin/parser.py",
>     line 222, in handle_starttag
>       File "/usr/local/lib/python3.6/site-packages/htmlmin/parser.py",
>     line 189, in _close_tags_up_to
>>     The pgAdmin Development Team are pleased to announce pgAdmin 4
>>     version 3.1. This release of pgAdmin 4 includes over 30 bug fixes
>>     and new features. For more details please see the release notes at:
>>
>>     https://www.pgadmin.org/docs/pgadmin4/dev/release_notes_3_1.html
>>     <https://www.pgadmin.org/docs/pgadmin4/dev/release_notes_3_1.html>.
>>
>>     Builds for Windows and macOS are available now, along with a
>>     Python Wheel, Docker Container and source code tarball from:
>>
>>     https://www.pgadmin.org/download/ <https://www.pgadmin.org/download/>
>>
>>     postgresql.org <http://postgresql.org> repositories within the
>>     next few days.
>>
>>     -- 
>>     Dave Page
>>     pgAdmin Project Lead
>>
>
>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 28 Jun 2018 16:45:05 +0530

Sorry, ​I didn't get you, what do mean when you say 'web is like only
text'? ​

On Thu, Jun 28, 2018 at 4:35 PM, Isaias Sanchez <[email-masked]>
wrote:

> This help a bit, I can log in, but the web is like only text, probably is
> necessary to update another:
>
> # pip3 freeze
> alembic==0.9.2
> asn1crypto==0.24.0
> Babel==2.3.4
> bcrypt==3.1.4
> beautifulsoup4==4.4.1
> blinker==1.4
> cffi==1.11.5
> click==6.6
> cryptography==2.2.2
> extras==1.0.0
> fixtures==3.0.0
> Flask==0.12.2
> Flask-Babel==0.11.1
> Flask-BabelEx==0.9.3
> Flask-Gravatar==0.5.0
> Flask-HTMLmin==1.3.2
> Flask-Login==0.3.2
> Flask-Mail==0.9.1
> Flask-Migrate==2.1.1
> Flask-Paranoid==0.2.0
> Flask-Principal==0.4.0
> Flask-Script==2.0.5
> Flask-Security==3.0.0
> Flask-SQLAlchemy==2.3.2
> Flask-WTF==0.14.2
> html5lib==1.0.1
> htmlmin==0.1.12
> idna==2.7
> itsdangerous==0.24
> Jinja2==2.7.3
> linecache2==1.0.0
> Mako==1.0.6
> MarkupSafe==0.23
> paramiko==2.4.1
> passlib==1.7.1
> pbr==3.1.1
> pgadmin4==3.1
> psycopg2==2.7.5
> psycopg2-binary==2.7.5
> pyasn1==0.4.3
> pycparser==2.18
> pycrypto==2.6.1
> PyNaCl==1.2.1
> pyrsistent==0.14.2
> python-dateutil==2.7.2
> python-editor==1.0.3
> python-mimeparse==1.6.0
> pytz==2018.3
> simplejson==3.13.2
> six==1.11.0
> speaklater==1.3
> SQLAlchemy==1.2.6
> sqlparse==0.2.4
> sshtunnel==0.1.4
> testtools==2.3.0
> traceback2==1.4.0
> unittest2==1.1.0
> webencodings==0.5.1
> Werkzeug==0.9.6
> WTForms==2.1
>
>
> On Thu, Jun 28, 2018 at 4:13 PM, Isaias Sanchez <
> [email-masked]> wrote:
>

---

From: Isaias Sanchez <[email-masked]>
Date: Thu, 28 Jun 2018 11:20:19 +0000

look at the screenshots:

scren1
screen2

On 28/06/18 11:15, Murtuza Zabuawala wrote:
> On Thu, Jun 28, 2018 at 4:35 PM, Isaias Sanchez 
>     This help a bit, I can log in, but the web is like only text,
>     probably is necessary to update another:
>
>     # pip3 freeze
>     alembic==0.9.2
>     asn1crypto==0.24.0
>     Babel==2.3.4
>     bcrypt==3.1.4
>     beautifulsoup4==4.4.1
>     blinker==1.4
>     cffi==1.11.5
>     click==6.6
>     cryptography==2.2.2
>     extras==1.0.0
>     fixtures==3.0.0
>     Flask==0.12.2
>     Flask-Babel==0.11.1
>     Flask-BabelEx==0.9.3
>     Flask-Gravatar==0.5.0
>     Flask-HTMLmin==1.3.2
>     Flask-Login==0.3.2
>     Flask-Mail==0.9.1
>     Flask-Migrate==2.1.1
>     Flask-Paranoid==0.2.0
>     Flask-Principal==0.4.0
>     Flask-Script==2.0.5
>     Flask-Security==3.0.0
>     Flask-SQLAlchemy==2.3.2
>     Flask-WTF==0.14.2
>     html5lib==1.0.1
>     htmlmin==0.1.12
>     idna==2.7
>     itsdangerous==0.24
>     Jinja2==2.7.3
>     linecache2==1.0.0
>     Mako==1.0.6
>     MarkupSafe==0.23
>     paramiko==2.4.1
>     passlib==1.7.1
>     pbr==3.1.1
>     pgadmin4==3.1
>     psycopg2==2.7.5
>     psycopg2-binary==2.7.5
>     pyasn1==0.4.3
>     pycparser==2.18
>     pycrypto==2.6.1
>     PyNaCl==1.2.1
>     pyrsistent==0.14.2
>     python-dateutil==2.7.2
>     python-editor==1.0.3
>     python-mimeparse==1.6.0
>     pytz==2018.3
>     simplejson==3.13.2
>     six==1.11.0
>     speaklater==1.3
>     SQLAlchemy==1.2.6
>     sqlparse==0.2.4
>     sshtunnel==0.1.4
>     testtools==2.3.0
>     traceback2==1.4.0
>     unittest2==1.1.0
>     webencodings==0.5.1
>     Werkzeug==0.9.6
>     WTForms==2.1
>
>
>>     Please install/update htmlmin to version 0.1.12, let us know if
>>     that solves the issue.
>>
>>     -- 
>>     Regards,
>>     Murtuza Zabuawala
>>     <http://www.enterprisedb.com/>
>>         I just installed the Python Wheel 3.1 version on a centos 6
>>         server and the app doesn't start, the error is this:
>>
>>         "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py",
>>         line 177, in run_wsgi
>>             execute(self.server.app)
>>           File
>>         "/usr/local/lib/python3.6/site-packages/werkzeug/serving.py",
>>         line 165, in execute
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1997, in __call__
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1985, in wsgi_app
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1540, in handle_exception
>>         "/usr/local/lib/python3.6/site-packages/flask/_compat.py",
>>         line 33, in reraise
>>             raise value
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1982, in wsgi_app
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1615, in full_dispatch_request
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1632, in finalize_request
>>           File "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>         line 1856, in process_response
>>         "/usr/local/lib/python3.6/site-packages/flask_htmlmin.py",
>>         "/usr/local/lib/python3.6/site-packages/htmlmin/main.py",
>>         line 152, in minify
>>             self.input(*input)
>>           File
>>         "/usr/local/lib/python3.6/site-packages/htmlmin/main.py",
>>         line 164, in input
>>             self._parser.feed(i)
>>           File "/usr/local/lib/python3.6/html/parser.py", line 345,
>>         in parse_starttag
>>         "/usr/local/lib/python3.6/site-packages/htmlmin/parser.py",
>>         "/usr/local/lib/python3.6/site-packages/htmlmin/parser.py",
>>>         The pgAdmin Development Team are pleased to announce pgAdmin
>>>         4 version 3.1. This release of pgAdmin 4 includes over 30
>>>         bug fixes and new features. For more details please see the
>>>         release notes at:
>>>
>>>         pgAdmin is the leading Open Source graphical management tool
>>>         for PostgreSQL. For more information, please see:
>>>
>>>         https://www.pgadmin.org/
>>>
>>>         <https://www.pgadmin.org/download/>
>>>
>>>         postgresql.org <http://postgresql.org> repositories within
>>>         the next few days.
>>>
>>>         -- 
>>>         Dave Page
>>>         pgAdmin Project Lead
>>>
>>
>>
>
>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 28 Jun 2018 17:03:17 +0530

What is your browser and its version?
Do you see any errors on browser console
<https://developers.google.com/web/tools/chrome-devtools/console/>?

On Thu, Jun 28, 2018 at 4:50 PM, Isaias Sanchez <[email-masked]>
wrote:

> On Thu, Jun 28, 2018 at 4:35 PM, Isaias Sanchez <

---

From: Isaias Sanchez <[email-masked]>
Date: Thu, 28 Jun 2018 11:47:23 +0000

Browsers:

Firefox 60.0.2

Chromium: 66.0.3359.181

The error in Firefox console is:

The stylesheet http://localhost:5050/login?next=%2Fbrowser%2Fbrowser.css 
was not loaded because its MIME type, “text/html”, is not “text/css”.

In Chormium:

style.css, pgadmin_commons.js and vendor.js NOT FOUND, the MIME in 
browser.css is just a Warning.

Regards,

Isaias S.

On 28/06/18 11:33, Murtuza Zabuawala wrote:
> On Thu, Jun 28, 2018 at 4:50 PM, Isaias Sanchez 
>>     Sorry, ​I didn't get you, what do mean when you say 'web is like
>>     only text'? ​
>>
>>
>>>         Please install/update htmlmin to version 0.1.12, let us know
>>>         if that solves the issue.
>>>
>>>         -- 
>>>         Regards,
>>>         Murtuza Zabuawala
>>>         <[email-masked]
>>>         <mailto:[email-masked]>> wrote:
>>>
>>>             I just installed the Python Wheel 3.1 version on a
>>>             centos 6 server and the app doesn't start, the error is
>>>             this:
>>>
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>             line 1997, in __call__
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>             line 1985, in wsgi_app
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>             line 1982, in wsgi_app
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>             "/usr/local/lib/python3.6/site-packages/flask/app.py",
>>>               File "/usr/local/lib/python3.6/html/parser.py", line
>>>             345, in parse_starttag
>>>>             The pgAdmin Development Team are pleased to announce
>>>>             pgAdmin 4 version 3.1. This release of pgAdmin 4
>>>>             includes over 30 bug fixes and new features. For more
>>>>             details please see the release notes at:
>>>>
>>>>             pgAdmin is the leading Open Source graphical management
>>>>             tool for PostgreSQL. For more information, please see:
>>>>
>>>>             https://www.pgadmin.org/
>>>>
>>>>             Builds for Windows and macOS are available now, along
>>>>             with a Python Wheel, Docker Container and source code
>>>>             tarball from:
>>>>
>>>>             RPM and DEB packages are expected to be available on
>>>>             the postgresql.org <http://postgresql.org> repositories
>>>>             within the next few days.
>>>>
>>>>             -- 
>>>>             Dave Page
>>>>             pgAdmin Project Lead
>>>>
>>>
>>>
>>
>>
>
>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 28 Jun 2018 17:34:32 +0530

Do you have any web server installed?
If yes then I suspect it is causing the issue because I can see in the code
that we are sending MIME headers properly as *{'Content-Type': 'text/css'}* for
browser.css

On Thu, Jun 28, 2018 at 5:17 PM, Isaias Sanchez <[email-masked]>
wrote:

> On Thu, Jun 28, 2018 at 4:50 PM, Isaias Sanchez <

---

From: Dave Page <[email-masked]>
Date: Thu, 28 Jun 2018 13:08:30 +0100

I've found the issue. Working on the fix...

On Thu, Jun 28, 2018 at 1:04 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> If yes then I suspect it is causing the issue because I can see in the
> code that we are sending MIME headers properly as *{'Content-Type':
> 'text/css'}* for browser.css
>
>
> On Thu, Jun 28, 2018 at 5:17 PM, Isaias Sanchez <
>>>>> postgresql.org repositories within the next few days.
>>>>>
>>>>> --
>>>>> Dave Page
>>>>> pgAdmin Project Lead
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Thu, 28 Jun 2018 13:26:12 +0100

OK, please go grab the wheel again, from thttps://www.postgresql.org/
ftp/pgadmin/pgadmin4/v3.1/pip/. The MD5 checksum should be:

1af9eb551f729958101e55b9a0eeae8d  pgadmin4-3.1-py2.py3-none-any.whl

This should contain the missing files and fixes to the wheel requirements.

Sorry about that - stupid case-sensitivity bug in a script :-(

On Thu, Jun 28, 2018 at 1:08 PM, Dave Page <[email-masked]> wrote:

> On Thu, Jun 28, 2018 at 1:04 PM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>>>>>> version 3.1. This release of pgAdmin 4 includes over 30 bug fixes and new

---

From: Isaias Sanchez <[email-masked]>
Date: Thu, 28 Jun 2018 13:27:53 +0000

it works like a charm!

Thanks Dave,

Isaias S.

Note: I'll try to help you guys with Spanish Translation, I'm taking a 
look to the documentation.

On 28/06/18 12:26, Dave Page wrote:
> OK, please go grab the wheel again, from 
> thttps://www.postgresql.org/ftp/pgadmin/pgadmin4/v3.1/pip/ 
> <http://www.postgresql.org/ftp/pgadmin/pgadmin4/v3.1/pip/>. The MD5 
> checksum should be:
>
> On Thu, Jun 28, 2018 at 1:08 PM, Dave Page <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     On Thu, Jun 28, 2018 at 1:04 PM, Murtuza Zabuawala
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         If yes then I suspect it is causing the issue because I can
>         see in the code that we are sending MIME headers properly as
>         /{'Content-Type': 'text/css'}/ for browser.css
>
>
>         On Thu, Jun 28, 2018 at 5:17 PM, Isaias Sanchez
>             The stylesheet
>             http://localhost:5050/login?next=%2Fbrowser%2Fbrowser.css
>             <http://localhost:5050/login?next=%2Fbrowser%2Fbrowser.css>
>             style.css, pgadmin_commons.js and vendor.js NOT FOUND, the
>             MIME in browser.css is just a Warning.
>
>             Regards,
>
>             Isaias S.
>
>>>                 Sorry, ​I didn't get you, what do mean when you say
>>>                 'web is like only text'? ​
>>>
>>>
>>>                     This help a bit, I can log in, but the web is
>>>                     like only text, probably is necessary to update
>>>                     another:
>>>
>>>                     # pip3 freeze
>>>                     alembic==0.9.2
>>>                     asn1crypto==0.24.0
>>>                     Babel==2.3.4
>>>                     bcrypt==3.1.4
>>>                     beautifulsoup4==4.4.1
>>>                     blinker==1.4
>>>                     cffi==1.11.5
>>>                     click==6.6
>>>                     cryptography==2.2.2
>>>                     extras==1.0.0
>>>                     fixtures==3.0.0
>>>                     Flask==0.12.2
>>>                     Flask-Babel==0.11.1
>>>                     Flask-BabelEx==0.9.3
>>>                     Flask-Gravatar==0.5.0
>>>                     Flask-HTMLmin==1.3.2
>>>                     Flask-Login==0.3.2
>>>                     Flask-Mail==0.9.1
>>>                     Flask-Migrate==2.1.1
>>>                     Flask-Paranoid==0.2.0
>>>                     Flask-Principal==0.4.0
>>>                     Flask-Script==2.0.5
>>>                     Flask-Security==3.0.0
>>>                     Flask-SQLAlchemy==2.3.2
>>>                     Flask-WTF==0.14.2
>>>                     html5lib==1.0.1
>>>                     htmlmin==0.1.12
>>>                     idna==2.7
>>>                     itsdangerous==0.24
>>>                     Jinja2==2.7.3
>>>                     linecache2==1.0.0
>>>                     Mako==1.0.6
>>>                     MarkupSafe==0.23
>>>                     paramiko==2.4.1
>>>                     passlib==1.7.1
>>>                     pbr==3.1.1
>>>                     pgadmin4==3.1
>>>                     psycopg2==2.7.5
>>>                     psycopg2-binary==2.7.5
>>>                     pyasn1==0.4.3
>>>                     pycparser==2.18
>>>                     pycrypto==2.6.1
>>>                     PyNaCl==1.2.1
>>>                     pyrsistent==0.14.2
>>>                     python-dateutil==2.7.2
>>>                     python-editor==1.0.3
>>>                     python-mimeparse==1.6.0
>>>                     pytz==2018.3
>>>                     simplejson==3.13.2
>>>                     six==1.11.0
>>>                     speaklater==1.3
>>>                     SQLAlchemy==1.2.6
>>>                     sqlparse==0.2.4
>>>                     sshtunnel==0.1.4
>>>                     testtools==2.3.0
>>>                     traceback2==1.4.0
>>>                     unittest2==1.1.0
>>>                     webencodings==0.5.1
>>>                     Werkzeug==0.9.6
>>>                     WTForms==2.1
>>>
>>>
>>>>                     Please install/update htmlmin to version
>>>>                     0.1.12, let us know if that solves the issue.
>>>>
>>>>                     -- 
>>>>                     Regards,
>>>>                     Murtuza Zabuawala
>>>>                         I just installed the Python Wheel 3.1
>>>>                         version on a centos 6 server and the app
>>>>                         doesn't start, the error is this:
>>>>
>>>>                         "/usr/local/lib/python3.6/html/parser.py",
>>>>                         line 111, in feed
>>>>                         self.goahead(0)
>>>>                           File
>>>>                         "/usr/local/lib/python3.6/html/parser.py",
>>>>                         line 171, in goahead
>>>>                         "/usr/local/lib/python3.6/html/parser.py",
>>>>                         line 345, in parse_starttag
>>>>>                         The pgAdmin Development Team are pleased
>>>>>                         to announce pgAdmin 4 version 3.1. This
>>>>>                         release of pgAdmin 4 includes over 30 bug
>>>>>                         fixes and new features. For more details
>>>>>                         please see the release notes at:
>>>>>
>>>>>                         pgAdmin is the leading Open Source
>>>>>                         graphical management tool for PostgreSQL.
>>>>>                         For more information, please see:
>>>>>
>>>>>                         https://www.pgadmin.org/
>>>>>
>>>>>                         Builds for Windows and macOS are available
>>>>>                         now, along with a Python Wheel, Docker
>>>>>                         Container and source code tarball from:
>>>>>
>>>>>                         <http://postgresql.org> repositories

---

From: Dave Page <[email-masked]>
Date: Thu, 28 Jun 2018 14:57:57 +0100

> it works like a charm!
\o/

> Thanks Dave,
You're welcome - sorry for the inconvenience.

> look to the documentation.

Cool, thanks. It's pretty simple actually; choose a PO file editor, grab a
copy of the template (
https://git.postgresql.org/gitweb/?p=pgadmin4.git;a=blob_plain;f=web/pgadmin/messages.pot),
and create the PO file from that. When you're done, send us the PO file and
we can add it.

Thanks again!

> OK, please go grab the wheel again, from thttps://www.postgresql.org/ft
> p/pgadmin/pgadmin4/v3.1/pip/. The MD5 checksum should be:
>
>>>> The stylesheet http://localhost:5050/login?ne
>>>> xt=%2Fbrowser%2Fbrowser.css was not loaded because its MIME type,
>>>> “text/html”, is not “text/css”.
>>>>
>>>> In Chormium:
>>>>
>>>>>>> .