Subject: PATCH: To fix the '/logout' redirects to '/' (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 23 Sep 2016 16:08:18 +0530

Hi,

PFA patch to fix the issue where '/logout' redirects to '/', which cause
issue if pgAdmin4 is running in virtual root environment.
RM#1691

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company
diff --git a/web/pgadmin/browser/templates/browser/index.html b/web/pgadmin/browser/templates/browser/index.html
index a914c00..5bd054a 100644
--- a/web/pgadmin/browser/templates/browser/index.html
+++ b/web/pgadmin/browser/templates/browser/index.html
@@ -156,7 +156,7 @@ require.onResourceLoad = function (context, map, depMaps) {
                         <li><a href="#" onclick="pgAdmin.Browser.UserManagement.show_users()">{{ _('Users') }}</a></li>
                         <li class="divider"></li>
                         {% endif %}
-                        <li><a href="{{ url_for('security.logout') }}">{{ _('Logout') }}</a></li>
+                        <li><a href="{{ url_for('security.logout') }}?next={{url_for('browser.index')}}">{{ _('Logout') }}</a></li>
                     </ul>
                 </li>
             </ul>

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 23 Sep 2016 13:14:34 +0100

Thanks, applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company