Subject: Server specific advanced config file for testsuite

From: Navnath Gadakh <[email-masked]>
Date: Mon, 12 Sep 2016 22:56:20 +0530

Hi Dave,
     As we know that, we are using two JSON files one is for basic
configuration of server(test_config.json) and second for detailed
configuration of server(test_advanced_config.json).
In test_advanced_config.json, we give detail for database, schema,
extension, collation etc. These details are generic I mean these details
are not server specific.
- Do we need to allow user to give server specific details?
If yes, there should be some identification(like ‘server_type’, ‘version’)
for each detail so that we can read server appropriate details.
We have one approach in mind, to attach 'server_type' & 'version' to each
detail
So, modified test_advanced_config.json can be like this,
{
"add_database_data”:[
{
 "conn_limit": -1,
 “owner”: “postres”,
  .
  .
  .
  .
 “server_type”: “pg”,
 “version”: “pg9.4”
},
{
{
 "conn_limit": -1,
 “owner”: “enterprisedb”,
  .
  .
  .
  .
 “server_type”: “ppas”,
 “version”: “ppas9.6”
}
}],
“schema_credentials”:
[{"func_acl": [],
  "seq_acl": [],
  .
  .
  .
  .
  “server_type”: “pg”,
  “version”: “pg9.4”
}]
.
.
.
.
.
}

Any suggestions?

For multiple server currently we used 'owner' to identify the server, but
that fails if two servers have the same owner.

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Sep 2016 09:48:08 +0100

Hi

On Mon, Sep 12, 2016 at 6:26 PM, Navnath Gadakh
<[email-masked]> wrote:
> extension, collation etc. These details are generic I mean these details are
> not server specific.

I don't see any reason to do so. Honestly I don't see much need for
test_advanced_config.json at all - I can't see anyone ever customising
the tests. I certainly doubt I will.

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Sep 2016 09:48:44 +0100

BTW - I need the updated code that fixes all outstanding issues this
week please. Release is coming up fast...

---

From: Navnath Gadakh <[email-masked]>
Date: Tue, 13 Sep 2016 14:36:21 +0530

Hi,

> week please. Release is coming up fast...

 Yes. The enhanced test result is already completed, but before that drop
objects functionality is needed to complete. Which is already done for
servers & databases. So I will send a patch for these two nodes today &
after that for the remaining nodes(need some modifications
in existing setup & teardown for each test module)

 We will try to finish this work end of this week.

 Thanks.

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Sep 2016 10:12:46 +0100

On Tue, Sep 13, 2016 at 10:06 AM, Navnath Gadakh
<[email-masked]> wrote:
> after that for the remaining nodes(need some modifications in existing setup
> & teardown for each test module)
>

https://goo.gl/FiPllO

:-)

---

From: Priyanka Shendge <[email-masked]>
Date: Tue, 13 Sep 2016 17:39:43 +0530

On 13 September 2016 at 14:18, Dave Page <[email-masked]> wrote:

> are

As per your suggestion, I have added test data to test_advanced_config.json
which will be used/changed by advanced user.
test_advanced_config.json contain test data for all nodes (i.e. database,
schema, tablespace etc..) except server.
If we dont use test_advanced_config.json file, from where we can fetch test
data for all nodes?
We wants to edit test_advanced_config.json as per server type and version
as there are 2 types of
servers available i.e. PostgreSQL and EPAS which might have different test
data as per server type.
e.g. "owner": in case of PG it can be owner: "postgres"
which may not be available for EPAS, for EPAS it can be "enterprisedb" or
vice versa.
If we do not modify the tests and run testsuite it will fail for multiple
servers.

-- 
Best,
Priyanka

EnterpriseDB Corporation

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Sep 2016 13:13:16 +0100

Hi

> which will be used/changed by advanced user.

I suggested it because I didn't think it should all be in the main
config file. I didn't realise it was going to get so big at the time.

> If we dont use test_advanced_config.json file, from where we can fetch test

Hard-code it in the tests.

> We wants to edit test_advanced_config.json as per server type and version as
> there are 2 types of

But that data is in the server config (test_config.json).

> If we do not modify the tests and run testsuite it will fail for multiple

I honestly don't see why anything other than server-specific values
(i.e. connection info, tablespace path) needs to be customisable.