Subject: pgAdmin 4 - desktop version - RPM

From: gmail Vladimir Koković <[email-masked]>
Date: Mon, 1 Mar 2021 16:24:57 +0100

After many years of using "pgAdmin III", I tried several times to run 
the "pgAdmin 4" desktop version, but always without success!

So it is on this day in an attempt to run 
pgadmin4-desktop-5.0-1.fc33.x86_64.rpm (snapshots/2021-03-01).
After extracting the files from the RPM to the /tmp/vk/rpm/desktop 
folder based on
the /tmp/vk/rpm/desktop/usr/share/applications/pgadmin4.desktop content 
and running pgadmin4:

/tmp/vk/rpm/desktop/usr/pgadmin4/bin/pgadmin4
folder /root/.local/share/pgadmin contains a log file which mysteriously 
disappears after the end of pgadmin4,
with the following content:

Python Path: "/tmp/vk/rpm/desktop/usr/pgadmin4/venv/bin/python3"
Runtime Config File: "/root/.config/pgadmin/runtime_config.json"
pgAdmin Config File: "/tmp/vk/rpm/desktop/usr/pgadmin4/web/config.py"
Webapp Path: "/tmp/vk/rpm/desktop/usr/pgadmin4/web/pgAdmin4.py"
pgAdmin Command: "/tmp/vk/rpm/desktop/usr/pgadmin4/venv/bin/python3 
/tmp/vk/rpm/desktop/usr/pgadmin4/web/pgAdmin4.py"
Failed to lauch pgAdmin4 with below error:
Error: spawn ../venv/bin/python3 ENOENT

/tmp/vk/rpm/desktop/usr/pgadmin4 does not contain "venv".

Vladimir Koković, DP senior(70),
Serbia, Belgrade, 1.March 2021

---

From: Dave Page <[email-masked]>
Date: Mon, 1 Mar 2021 15:48:51 +0000

On Mon, Mar 1, 2021 at 3:25 PM gmail Vladimir Koković <
[email-masked]> wrote:

> After many years of using "pgAdmin III", I tried several times to run the
> "pgAdmin 4" desktop version, but always without success!
>
> After extracting the files from the RPM to the /tmp/vk/rpm/desktop folder
> based on

No, it wouldn't. The RPMs have dependencies, and by doing what you have
done here, those dependencies are not satisfied. At the very least you'll
need to unpack the -server RPM into the same directory (and have
libatomic, python3, postgresql-libs >= 11 and krb5-libs *properly*
installed), and even then I'm not 100% sure it'll work as the packaging was
neither designed or tested for manual unpacking and relocation.

If you follow the installation instructions on the website, it should work
just fine.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

---

From: gmail Vladimir Koković <[email-masked]>
Date: Mon, 1 Mar 2021 17:03:22 +0100

Hi Dave,

You are absolutely right, you need to extract the server first and then 
the desktop RPM and the "pgAdmin 4" desktop version works!

By the way, I'm on Linux Manjaro for which you don't have a package and 
that's why it's easiest to use the RPM package.

On 1.3.21. 16:48, Dave Page wrote:
>
>
> On Mon, Mar 1, 2021 at 3:25 PM gmail Vladimir Koković 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     After many years of using "pgAdmin III", I tried several times to
>     run the "pgAdmin 4" desktop version, but always without success!
>
>     the /tmp/vk/rpm/desktop/usr/share/applications/pgadmin4.desktop
>     content and running pgadmin4:
>
>     folder /root/.local/share/pgadmin contains a log file which
>     mysteriously disappears after the end of pgadmin4,
>     pgAdmin Command:
>     "/tmp/vk/rpm/desktop/usr/pgadmin4/venv/bin/python3
> No, it wouldn't. The RPMs have dependencies, and by doing what you 
> have done here, those dependencies are not satisfied. At the very 
> least you'll need to unpack the -server RPM into the same directory 
> (and have libatomic, python3, postgresql-libs >= 11 and krb5-libs 
> *properly* installed), and even then I'm not 100% sure it'll work as 
> the packaging was neither designed or tested for manual unpacking and 
> relocation.
>
> If you follow the installation instructions on the website, it should 
> work just fine.
>
> -- 
> Dave Page
> Blog: http://pgsnake.blogspot.com <http://pgsnake.blogspot.com>
> Twitter: @pgsnake
>
> EDB: http://www.enterprisedb.com <http://www.enterprisedb.com>
>

---

From: Dave Page <[email-masked]>
Date: Mon, 1 Mar 2021 16:10:01 +0000

> that's why it's easiest to use the RPM package.

Cool - glad it's working for you!