Subject: [pgAdmin4][RM#3154] Update modules to latest version

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 30 Mar 2018 12:31:44 +0530

Hi,

PFA patch to update the modules to latest version.

We are not able to update some of the modules to latest version due to
dependancy on other modules, For example
- Python: Flask-Security has dependancy on flask-babelex which causes
conflict with flask_babel
- JS: Can't update to Bootstrap4 because Bootstrap Switch & Bootstrap Datetime
picker has dependancy on Bootstrap3.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Victoria Henry <[email-masked]>
Date: Fri, 30 Mar 2018 10:29:15 -0400

Hi Murtuza,

I ran this patch through the pipelines and all tests passed.
Everything looks good.

Sinerely,

Victoria

---

From: Murtuza Zabuawala <[email-masked]>
Date: Sat, 31 Mar 2018 12:23:46 +0530

Thanks for reviewing Victoria.

On Fri, Mar 30, 2018 at 7:59 PM, Victoria Henry <[email-masked]> wrote:

> On Fri, Mar 30, 2018 at 3:01 AM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi,
>>

---

From: Dave Page <[email-masked]>
Date: Tue, 3 Apr 2018 13:57:23 +0100

Hi

> PFA patch to update the modules to latest version.
- Why isn't jQuery updated to 3.3.1?

- Shouldn't pkg/pip/setup_pip.py be updated with changes to psycopg2 and
pycrypto etc?

> conflict with flask_babel

Hmm, flask-babelex might be a better option anyway; in particular, it
avoids loading catalogs with every request which seems desirable given the
size of ours. On the other hand, it hasn't been updated so recently.

> picker has dependancy on Bootstrap3.

OK.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 3 Apr 2018 20:20:20 +0530

Hi Dave,

Please find updated patches, there are two patches attached one is for the
story and another is for changes required as per new modules.

On Tue, Apr 3, 2018 at 6:27 PM, Dave Page <[email-masked]> wrote:

> Hi
>
> On Fri, Mar 30, 2018 at 8:01 AM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi,
>>
​Done​

> ​

> - Shouldn't pkg/pip/setup_pip.py be updated with changes to psycopg2 and
​Done​

> size of ours. On the other hand, it hasn't been updated so recently.
​I have removed flask-babel and used flask_babelex instead.​

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 3 Apr 2018 20:50:16 +0530

Please hold on my previous patch.

We can't use latest jQuery version as SlickGrid has dependancy on older
version.
I'll send updated patch again.

---

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 3 Apr 2018 21:19:48 +0530

​Hi Dave,

Reverted back jQuery version to 1.x because of SlickGrid dependancy.
Please find updated patch.

On Tue, Apr 3, 2018 at 8:50 PM, Murtuza Zabuawala <
[email-masked]> wrote:

> On Tue, Apr 3, 2018 at 8:20 PM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi Dave,
>>
>> Please find updated patches, there are two patches attached one is for
>> the story and another is for changes required as per new modules.
>>
>>

---

From: Joao De Almeida Pereira <[email-masked]>
Date: Tue, 03 Apr 2018 20:09:16 +0000

Hi Murtuza,

The patches look good and they pass all tests in CI.
One think that we realized was the SlickGrid as a npm package now:
https://www.npmjs.com/package/slickgrid
Also Slickgrid comes packaged with jquery 3.1 not sure if it is fully
supported or not......

Thanks
Victoria & Joao

On Tue, Apr 3, 2018 at 11:50 AM Murtuza Zabuawala <
[email-masked]> wrote:

>>>> - Shouldn't pkg/pip/setup_pip.py be updated with changes to psycopg2
>>>> and pycrypto etc?
>>>>
>>> ​Done​
>>>
>>>
>>>>
>>>>
>>>>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 4 Apr 2018 12:54:44 +0530

Hi Joao,

Yes it bundles latest version but I doubt that is not using it, If we
upgrade the jQuery to 3.3.1 then it's breaking the SlickGrid.
I have tried that and I started getting jQuery related errors when trying
to run query tool or when running jasmine tests.

On Wed, Apr 4, 2018 at 1:39 AM, Joao De Almeida Pereira <
[email-masked]> wrote:

> On Tue, Apr 3, 2018 at 11:50 AM Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> ​Hi Dave,
>>
>> On Tue, Apr 3, 2018 at 8:50 PM, Murtuza Zabuawala <murtuza.zabuawala@
>> enterprisedb.com> wrote:
>>
>>>>>> We are not able to update some of the modules to latest version due
>>>>>> to dependancy on other modules, For example
>>>>>> - JS: Can't update to Bootstrap4 because Bootstrap Switch &
>>>>>> Bootstrap Datetime picker has dependancy on Bootstrap3.
>>>>>>
>>>>>
>>>>> OK.
>>>>>
>>>>>
>>>>> --
>>>>> Dave Page

---

From: Dave Page <[email-masked]>
Date: Wed, 4 Apr 2018 10:47:49 +0100

Thanks, patch applied.

---

From: Dave Page <[email-masked]>
Date: Wed, 4 Apr 2018 10:49:28 +0100

> to run query tool or when running jasmine tests.

Can you spend some time trying to figure it out please? We need to get on
to 3.x as older versions are no longer receiving updates which could pose a
security risk.

>>>>>>> - Python: Flask-Security has dependancy on flask-babelex which
>>>>>>> causes conflict with flask_babel
>>>>>>>
>>>>>>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 4 Apr 2018 15:20:44 +0530

On Wed, Apr 4, 2018 at 3:19 PM, Dave Page <[email-masked]> wrote:

>
>
> On Wed, Apr 4, 2018 at 8:24 AM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hi Joao,
>>
​Sure Dave.​

>>>>> We can't use latest jQuery version as SlickGrid has dependancy on
>>>>> older version.
>>>>>> Please find updated patches, there are two patches attached one is
>>>>>> for the story and another is for changes required as per new modules.
>>>>>>
>>>>>>
>>>>>>> Hmm, flask-babelex might be a better option anyway; in particular,
>>>>>>> it avoids loading catalogs with every request which seems desirable given
>>>>>>> the size of ours. On the other hand, it hasn't been updated so recently.
>>>>>>>

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 6 Apr 2018 13:22:15 +0530

Hi Dave,

I checked and found that the issue was in wcDocker which was causing
problem while opening query tool,
I have logged an issue on github:
https://github.com/WebCabin/wcDocker/issues/124

Query tool, Debugger etc are working properly when open in new Browser Tab
and not in Panel.

I'm also able to fix the issue which I was facing while running Jasmine
test by correctting the path for *jquery.event.drag* library from
jquery.event.drag-2.2 to jquery.event.drag-2.3.0.

Let's wait for author's reply on the issue.

On Wed, Apr 4, 2018 at 3:20 PM, Murtuza Zabuawala <
[email-masked]> wrote:

>>> I have tried that and I started getting jQuery related errors when
>>> trying to run query tool or when running jasmine tests.
>>>
>>
>>>>>>>> - Shouldn't pkg/pip/setup_pip.py be updated with changes to
>>>>>>>> psycopg2 and pycrypto etc?
>>>>>>>>
>>>>>>> ​Done​
>>>>>>>
>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>> We are not able to update some of the modules to latest version
>>>>>>>>> due to dependancy on other modules, For example

---

From: Dave Page <[email-masked]>
Date: Fri, 6 Apr 2018 08:55:47 +0100

On Fri, Apr 6, 2018 at 8:52 AM, Murtuza Zabuawala <
[email-masked]> wrote:

> I have logged an issue on github: https://github.com/
> WebCabin/wcDocker/issues/124
>

Great, thanks.

> On Wed, Apr 4, 2018 at 3:20 PM, Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>>> Can you spend some time trying to figure it out please? We need to get
>>> on to 3.x as older versions are no longer receiving updates which could
>>> pose a security risk.
>>>
>> ​Sure Dave.​
>>
>>
>>>
>>>
>>>>
>>>> --
>>>> Regards,
>>>> Murtuza Zabuawala