Subject: [pgAdmin4][Patch]: Fixed an issue related to the Property dialogue buttons in IE 10

From: Khushboo Vashi <[email-masked]>
Date: Fri, 6 May 2016 19:15:47 +0530

Hi,

In IE (ver: 10), the Save/Reset buttons are not getting enabled even after
changing the fields.

Please find the attached patch for the same.

Thanks,
Khushboo
diff --git a/web/pgadmin/browser/templates/browser/js/node.js b/web/pgadmin/browser/templates/browser/js/node.js
index 5810e74..6289c2d 100644
--- a/web/pgadmin/browser/templates/browser/js/node.js
+++ b/web/pgadmin/browser/templates/browser/js/node.js
@@ -787,8 +787,8 @@ function($, _, S, pgAdmin, Menu, Backbone, Alertify, pgBrowser, Backform) {
           var updateButtons = function(hasError, modified) {
 
             var btnGroup = this.find('.pg-prop-btn-group'),
-                btnSave = btnGroup.find('button[type="save"]'),
-                btnReset = btnGroup.find('button[type="reset"]');
+                btnSave = btnGroup.find('button.btn-primary'),
+                btnReset = btnGroup.find('button.btn-warning');
 
             if (hasError || !modified) {
               btnSave.prop('disabled', true);

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 6 May 2016 15:30:45 +0100

Thanks, applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company