Subject: [RM4255] Geometry Viewer captures keys in Firefox, Edge and Internet Explorer

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 4 Jun 2019 11:23:39 +0530

Hi Hackers,

Attached is the patch to fix a focus issue in geometry view for browsers
other than chrome.
If geometry viewer is not visible (in wcDocker) and it loses focus, then
blur event is triggered for geometry viewer only in chrome, but other
browsers do not tigger blur event as the element is not visible. Code is
changed to explicitly fire blur event in visibility hidden.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Wed, 5 Jun 2019 12:00:25 +0100

Thanks, applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company