Subject: Styling SQL box layout on dialogue

From: Arun Kollan <[email-masked]>
Date: Thu, 7 Apr 2016 15:35:16 +0100

Hi Team,
please find attached css styling changes for SQL box layout on dialogue boxes.  The SQL box fills the entire control space with no margin for the gutter. 

Regards,
Arun Kollan
Website: www.enterprisedb.com <http://www.enterprisedb.com/>
EnterpriseDB Blog: http://blogs.enterprisedb.com/ <http://blogs.enterprisedb.com/>
Follow us on Twitter: http://www.twitter.com/enterprisedb <http://www.twitter.com/enterprisedb>

This e-mail message (and any attachment) is intended for the use of the individual or entity to whom it is addressed. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient or authorized to receive this for the intended recipient, any use, dissemination, distribution, retention, archiving, or copying of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message.

---

From: Dave Page <[email-masked]>
Date: Thu, 7 Apr 2016 15:53:39 +0100

On Thu, Apr 7, 2016 at 3:35 PM, Arun Kollan
<[email-masked]> wrote:
> Hi Team,
> please find attached css styling changes for SQL box layout on dialogue
> boxes.  The SQL box fills the entire control space with no margin for the
> gutter.

Per office discussion, this breaks the vertical sizing in the
browser's SQL tab. Arun to re-work.

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Arun Kollan <[email-masked]>
Date: Fri, 8 Apr 2016 14:23:01 +0100

Hi Team,

please find attached the patch for styling the sql editor on a dialogue
window.  The separate rule has been written to include the style specific
to a control window.

Regards,

Arun Kollan

---

From: Dave Page <[email-masked]>
Date: Mon, 11 Apr 2016 10:09:03 +0100

On Fri, Apr 8, 2016 at 2:23 PM, Arun Kollan
<[email-masked]> wrote:
> window.  The separate rule has been written to include the style specific to
> a control window.

There still seem to be padding/margin issues on my machine (under
Chrome). Am I missing something?

---

From: Arun Kollan <[email-masked]>
Date: Mon, 11 Apr 2016 10:45:12 +0100

Hi Dave,
 Looks the like the patch is out of sync with the repository. I will create another patch now. 

Regards,
Arun Kollan

> On 11 Apr 2016, at 10:09, Dave Page <[email-masked]> wrote:
> 
> <Screen Shot 2016-04-11 at 10.07.08.png>

---

From: Arun Kollan <[email-masked]>
Date: Mon, 11 Apr 2016 11:31:09 +0100

Hi Dave,
 Please find attached the zipped version of the patch. I have tested it against the latest version from the repository.  I had quick look comparing the patches and it looks to contain the same rules. 

Regards,

Arun Kollan

> On 11 Apr 2016, at 10:45, Arun Kollan <[email-masked]> wrote:
> 
> Hi Dave,
>> On 11 Apr 2016, at 10:09, Dave Page <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>> Hi Team,
>>> 
>> EnterpriseDB: http://www.enterprisedb.com <http://www.enterprisedb.com/>
>> Blog: http://pgsnake.blogspot.com <http://pgsnake.blogspot.com/>
>> Twitter: @pgsnake

---

From: Dave Page <[email-masked]>
Date: Mon, 11 Apr 2016 13:33:22 +0100

Still looks the same as my last screenshot to me.

On Mon, Apr 11, 2016 at 11:31 AM, Arun Kollan
<[email-masked]> wrote:
> Hi Dave,
>  Please find attached the zipped version of the patch. I have tested it
> against the latest version from the repository.  I had quick look comparing
> the patches and it looks to contain the same rules.
>
>
> Regards,
>
> Arun Kollan
> Website: www.enterprisedb.com
> EnterpriseDB Blog: http://blogs.enterprisedb.com/
> Follow us on Twitter: http://www.twitter.com/enterprisedb
>
> This e-mail message (and any attachment) is intended for the use of the
> individual or entity to whom it is addressed. This message contains
> information from EnterpriseDB Corporation that may be privileged,
> confidential, or exempt from disclosure under applicable law. If you are not
> the intended recipient or authorized to receive this for the intended
> recipient, any use, dissemination, distribution, retention, archiving, or
> copying of this communication is strictly prohibited. If you have received
> this e-mail in error, please notify the sender immediately by reply e-mail
> and delete this message.
>
>
>
>
> Website: www.enterprisedb.com
> EnterpriseDB Blog: http://blogs.enterprisedb.com/
> Follow us on Twitter: http://www.twitter.com/enterprisedb
>
> This e-mail message (and any attachment) is intended for the use of the
> individual or entity to whom it is addressed. This message contains
> information from EnterpriseDB Corporation that may be privileged,
> confidential, or exempt from disclosure under applicable law. If you are not
> the intended recipient or authorized to receive this for the intended
> recipient, any use, dissemination, distribution, retention, archiving, or
> copying of this communication is strictly prohibited. If you have received
> this e-mail in error, please notify the sender immediately by reply e-mail
> and delete this message.
>
>
>
>

---

From: Arun Kollan <[email-masked]>
Date: Mon, 11 Apr 2016 13:59:50 +0100

Hi Dave,
 I asked Murtuza to apply the patch at his end and test on Chrome and Firefox. We had a Skype session and it does appear to fix the issue.  It required a hard reload and cache clearing to get it working. 

I am assuming that the screenshot displayed is the dialogue window for database properties. 

Regards,
Arun Kollan

> On 11 Apr 2016, at 13:33, Dave Page <[email-masked]> wrote:
>

---

From: Dave Page <[email-masked]>
Date: Tue, 12 Apr 2016 16:55:36 +0100

OK, taking another look it seems like it's bit-rotted. Can you rebase please?

Thanks.

piranha:web dpage$ git pull
Already up-to-date.
piranha:web dpage$ git apply ~/Downloads/sql-box-layout-stylingv2.patch
/Users/dpage/Downloads/sql-box-layout-stylingv2.patch:9: trailing whitespace.
.pgadmin-controls.SQL {
/Users/dpage/Downloads/sql-box-layout-stylingv2.patch:10: trailing whitespace.
  min-width: 290px;
/Users/dpage/Downloads/sql-box-layout-stylingv2.patch:11: trailing whitespace.
  padding-right: 3px;
/Users/dpage/Downloads/sql-box-layout-stylingv2.patch:12: trailing whitespace.
  padding-left: 1px;
/Users/dpage/Downloads/sql-box-layout-stylingv2.patch:13: trailing whitespace.
}
error: patch failed: web/pgadmin/static/css/overrides.css:276
error: web/pgadmin/static/css/overrides.css: patch does not apply
error: patch failed: web/pgadmin/static/js/backform.pgadmin.js:519
error: web/pgadmin/static/js/backform.pgadmin.js: patch does not apply

On Mon, Apr 11, 2016 at 1:59 PM, Arun Kollan
<[email-masked]> wrote:
> Hi Dave,
>  I asked Murtuza to apply the patch at his end and test on Chrome and
> Firefox. We had a Skype session and it does appear to fix the issue.  It
> required a hard reload and cache clearing to get it working.
>