Subject: [pgadmin4][Patch]: Fixed minor issue in auto discover server when entry is blank in the config file

From: Akshay Joshi <[email-masked]>
Date: Thu, 21 Jun 2018 13:02:58 +0530

Hi Hackers,

I have found one minor issue in auto discovery logic. *getint* function of
ConfigParser throws exception if the value of the parameter is blank in the
config file. Example: *Port=*

Because of that exception pgAdmin4 unable to discover all the valid
servers. Attached is the patch to fix that. Please review it.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Thu, 21 Jun 2018 21:35:01 +0100

Thanks, applied.

On Thu, Jun 21, 2018 at 8:32 AM, Akshay Joshi <[email-masked]
> wrote:

> Hi Hackers,
>
> I have found one minor issue in auto discovery logic. *getint* function
> of ConfigParser throws exception if the value of the parameter is blank
> in the config file. Example: *Port=*
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company