Subject: PATCH: To fix the issue in exclusion constraint (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 30 Dec 2016 15:17:39 +0530

Hi,

PFA patch to fix the issue where we were fetching wrong OID while
generating node which was causing "index out of range". error when user try
to access that exclusion constraint .
RM#1896

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Sun, 8 Jan 2017 13:43:37 +0000

Hi

On Friday, December 30, 2016, Murtuza Zabuawala <
[email-masked]> wrote:

> generating node which was causing "index out of range". error when user
> try to access that exclusion constraint .
> RM#1896
>

I can't reproduce this, even following the steps in the ticket. How did you
manage to reproduce it?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Mon, 9 Jan 2017 14:42:27 +0530

Hi

On Mon, Jan 9, 2017 at 10:46 AM, Murtuza Zabuawala
<[email-masked]> wrote:
> Hi Dave,
>
> I followed,
>
> 1) First click on main properties panel.
>
> 2) Sample definition,
>
> CREATE TABLE public.test_table
> (
>     id character varying(3) COLLATE pg_catalog."default" NOT NULL,
>     col1 bigint,
>     CONSTRAINT test_pkey PRIMARY KEY (id)
> )
> WITH (
>     OIDS = FALSE
> )
> TABLESPACE pg_default;
>
> With above created table, create exclusion constraint with following options
> using GUI,
>
> ALTER TABLE public.test_table
>     ADD CONSTRAINT test_exclu EXCLUDE USING btree (
>     col1 DESC NULLS LAST WITH =);
>
> Click on Save, Exclusion constraint will be created successfully but you
> will get error as wrong OID was sent while generating node info.

Nope - it works fine for me. I wonder what's different...

---

From: Dave Page <[email-masked]>
Date: Mon, 9 Jan 2017 15:05:59 +0530

Patch applied (once Murtuza showed me how to recreate the problem).

Thanks!