Subject: [pgAdmin][RM6130] React based framework for properties dialog and port Server Group, Server and Database dialogs

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 17 Jun 2021 15:30:25 +0530

Hi Hackers,

Attached patch marks the beginning of migrating properties dialog/tab to
React based code, which is easy to maintain, performant and testable using
automation.
Patch includes:
- Framework for creating React based dynamic form view out of a pre-defined
UI schema. Previously, it was based on Backform/Backbone.
- The new framework and components will use MaterialUI as base. Previously,
Bootstrap/Backform/jQuery components were used.
- The new code uses JSS instead of CSS since material ui and most modern
React libraries also use JSS. In future, this will allow us to change
the theme in real-time without refresh.
- 90% code covered by 80-85 new jasmine test cases.
- Server group node UI Schema migration to new, with schema test cases.
- Server node UI Schema migration to new, with schema test cases.
- Database node UI Schema migration to new, with schema test cases.
- Few other UI changes.

PS: Until all the nodes are migrated, this will not go in the main branch.
References:
https://material-ui.com/
https://cssinjs.org/
https://react-select.com/
https://react-table.tanstack.com/

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Thu, 17 Jun 2021 14:56:35 +0100

Hi

On Thu, Jun 17, 2021 at 11:01 AM Aditya Toshniwal <
[email-masked]> wrote:

> - Framework for creating React based dynamic form view out of a
> pre-defined UI schema. Previously, it was based on Backform/Backbone.
> - The new framework and components will use MaterialUI as base.
> Previously, Bootstrap/Backform/jQuery components were used.

Nice!

> PS: Until all the nodes are migrated, this will not go in the main branch.

Yeah, how are we going to manage this? I agree with building it out in a
branch until we have full coverage of the dialogues, but I'm concerned that
it'll become a merge nightmare. Though, I guess we aren't touching the
dialogues much for other things right now, so maybe not.

-- 
Dave Page
Blog: https://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: https://www.enterprisedb.com

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 21 Jun 2021 09:35:13 +0530

Hi Dave,

> dialogues much for other things right now, so maybe not.
We'll right now work only on the dialogs. So merging should be manageable.
BTW, the patch can be merged in the main branch as well. It is backward
compatible, and it will work fine. Only the UI components would look
slightly different from the non-migrated dialogs.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 24 Jun 2021 17:38:32 +0530

Thanks, the patch applied in the "React_Porting" branch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 28 Jun 2021 14:50:36 +0530

Hi Hackers,

I made some changes to the core code that will be helpful for other nodes.
Please review.

On Thu, Jun 24, 2021 at 5:39 PM Akshay Joshi <[email-masked]>
wrote:

>>>> Attached patch marks the beginning of migrating properties dialog/tab
>>>> to React based code, which is easy to maintain, performant and testable
>>>> using automation.
>>>> Patch includes:
>>>> - The new code uses JSS instead of CSS since material ui and most
>>>> modern React libraries also use JSS. In future, this will allow us to
>>>> change the theme in real-time without refresh.

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 28 Jun 2021 15:57:10 +0530

Hi Hackers,

Please ignore the previous patch. Attached is the revised patch.

On Mon, Jun 28, 2021 at 2:50 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Thu, Jun 24, 2021 at 5:39 PM Akshay Joshi <
> [email-masked]> wrote:
>
>>>> Yeah, how are we going to manage this? I agree with building it out in
>>>> a branch until we have full coverage of the dialogues, but I'm concerned
>>>> that it'll become a merge nightmare. Though, I guess we aren't touching the

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 29 Jun 2021 14:39:06 +0530

Thanks, the patch applied.