Subject: Finalizing pgadmin4 RPM work

From: Devrim Gündüz <[email-masked]>
Date: Fri, 09 Sep 2016 11:15:16 +0300

Hi,

I committed pgadmin4 WIP spec file a few days ago, and now I'd like to finalize
the packaging.

Right now, we have 2 packages:

* pgadmin4-1.0-rc1_1.f24.x86_64 , includes:
  /usr/pgadmin4-1.0/runtime/pgAdmin4
  /usr/pgadmin4-1.0/runtime/pgadmin4.ini

* pgadmin4-web-1.0-rc1_1.f24.noarch , includes:
 - the rest.

So, what is next? I assume I'd need to add a unit file / init script, right?
Anything I'm missing?

Regards,
-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Dave Page <[email-masked]>
Date: Fri, 9 Sep 2016 11:26:31 +0100

Hi

> I committed pgadmin4 WIP spec file a few days ago, and now I'd like to finalize

Cool.

> So, what is next? I assume I'd need to add a unit file / init script, right?

For users to run in desktop mode, nothing else should be required,
except possibly a shortcut to the runtime executable.

For all users, a config_distro.py file may be needed to to override
any of the default config settings with distro specific values.

For users running in web mode, an Apache HTTPD config snippet should
be adding in /etc/httpd/conf.d. That should look something like this
(for httpd 2.4 - the Require All Granted will be different on earlier
version):

    WSGIDaemonProcess pgadmin processes=1 threads=25
    WSGIScriptAlias /pgadmin4 /opt/pgAdmin4/web/pgAdmin4.wsgi

    <Directory /opt/pgAdmin4/web>
        WSGIProcessGroup pgadmin
        WSGIApplicationGroup %{GLOBAL}
        Require all granted
    </Directory>

Finally; are you building and including the docs? Their location will
need to be in the config.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 11 Sep 2016 12:01:59 +0300

Hi,

> except possibly a shortcut to the runtime executable.

Any chance to add .desktop file to git, like we did for pgadmin3?

> any of the default config settings with distro specific values.

Ok, noted.

>         WSGIApplicationGroup %{GLOBAL}

Done.

> need to be in the config.

Done.

Thank you!

Cheers,

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Sep 2016 09:56:21 +0100

> Any chance to add .desktop file to git, like we did for pgadmin3?

Sure - I'd want to put it alongside the spec file. Have you written one?

>> need to be in the config.

Cool - and, thank *you* :-)

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 12 Sep 2016 13:42:51 +0300

Hi Dave,

> Sure - I'd want to put it alongside the spec file. Have you written one?

Just committed my version to pgrpms git:

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=commit;h=ad00835b6bb3615eebde2f253ebef438d3c27d48

I replace PYTHONDIR and  PYTHONSITELIB within the spec file using sed, so that
the same desktop file can work on PY3 and PY2 environments.

Cheers,

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Sep 2016 11:46:16 +0100

> the same desktop file can work on PY3 and PY2 environments.

Awesome - thanks Devrim! I owe you a nice cool glass of spring water :-)

Let me know when packages available and ready to use, and I'll add a
page to the website to point people at them.

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 16 Sep 2016 11:17:04 +0300

Hi,

> Awesome - thanks Devrim! I owe you a nice cool glass of spring water :-)

\o/ Can't wait ;)

> page to the website to point people at them.

They are currently available for 9.6 only, on yum.postgresql.org. All testing
has been good so far. Feel free to add info to pgadmin website. I am planning
to write a short blog post about that soon, about installation instructions,
running, etc.

Cheers,

---

From: Seçkin Alan <[email-masked]>
Date: Fri, 16 Sep 2016 11:42:45 +0300

Hi Devrim,

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=blob;f=rpm/redhat/9.6/pgadmin4/F-24/pgadmin4.desktop.in;h=362c0368fe54bd9b83fa55f57458af150d7d0942;hb=ad00835b6bb3615eebde2f253ebef438d3c27d48

Could you look this file ?

this variable is incorrect
Name=pgAdmin III

Its should be
Name=pgAdmin 4
or
Name=pgAdmin IV

Thanks.

-- 
Seçkin ALAN
http://sckn.org

---

From: Dave Page <[email-masked]>
Date: Fri, 16 Sep 2016 09:53:43 +0100

pgAdmin 4 is the correct speeling :-)

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 16 Sep 2016 12:35:59 +0300

Hi Seçkin,

On Fri, 2016-09-16 at 11:42 +0300, Seçkin Alan wrote:
> https://git.postgresql.org/gitweb/?p=pgrpms.git;a=blob;f=rpm/redhat/9.6/pgadm
> in4/F-
> 24/pgadmin4.desktop.in;h=362c0368fe54bd9b83fa55f57458af150d7d0942;hb=ad00835b
> 6bb3615eebde2f253ebef438d3c27d48
> 

Good catch! Fixed, thanks!

Cheers,

---

From: Dave Page <[email-masked]>
Date: Mon, 19 Sep 2016 12:03:52 +0100

> to write a short blog post about that soon, about installation instructions,

https://www.pgadmin.org/download/linux4.php

How's that? If you have instructions, please send me text (or better
yet, a patch), and I'll add them.

Thanks!

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 21 Sep 2016 13:09:21 +0300

Hi Dave,

> yet, a patch), and I'll add them.

I added packages for 9.4 and 9.5, too. Also wrote a basic blog post about this:

https://people.planetpostgresql.org/devrim/index.php?/archives/91-Installing-pgadmin4-to-Red-Hat,-CentOS,-and-Fedora.html

Cheers,