Subject: pgAdmin IV: Unittests-drop objects functionality

From: Navnath Gadakh <[email-masked]>
Date: Tue, 13 Sep 2016 20:09:23 +0530

Hi Dave,
     Please find the patch for drop objects functionality for test
framework.
Now, test framework is able to drop all objects(like server, database,
schema, etc.) which are created during test suite execution. Code included
in the patch is only for server and database node. If everything goes fine
will send next patch with the remaining nodes in a single patch.

*The following files are also affected by the new changes:*
web/setup.py,
web/config.py,
regression/test_advanced_config.json.in

*To run the test suite follow the commands*
1. python runtionregress/ests.py --pkg browser.server_groups.servers
2. python regression/runtests.yp --pkg browser.server_groups.servers.
databases

*Note: *Please do not run test suite for all nodes (python
regression/runtests.py) as code modifications have not been done yet.

Thanks.

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Sep 2016 12:55:15 +0100

Hi

On Tue, Sep 13, 2016 at 3:39 PM, Navnath Gadakh
<[email-masked]> wrote:
> The following files are also affected by the new changes:
> web/setup.py,
> web/config.py,
> To run the test suite follow the commands
> 2. python regression/runtests.yp --pkg
> browser.server_groups.servers.databases
>
>
> Note: Please do not run test suite for all nodes (python

I'm happy with this in general, except the changes in setup.py

- Let's use the names PGADMIN_SETUP_EMAIL and PGADMIN_SETUP_PASSWORD
for the envvars.

- Why are you setting the username and password in the environment
after prompting the user for them? I can't see why you're doing that,
and it's almost certainly a security issue.

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

---

From: Navnath Gadakh <[email-masked]>
Date: Wed, 14 Sep 2016 19:27:24 +0530

Hi Dave,

Please find the revised patch with suggested modifications.

> - Let's use the names PGADMIN_SETUP_EMAIL and PGADMIN_SETUP_PASSWORD

Sure.

> and it's almost certainly a security issue.
I was trying some different logic, by mistake that code remains, removed
that code in the attached patch.

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Sep 2016 16:26:25 +0100

Cool - thanks, committed!