Subject: [pgAdmin4][Patch]: RM1397 - File upload not working in File Manager in pgAdmin4 Runtime

From: Surinder Kumar <[email-masked]>
Date: Thu, 4 Aug 2016 18:29:03 +0530

Hi

*Issue:*
When a file is uploaded via FileManager it gets storage directory path from
STORAGE_DIR config variable. but in case of pgAdmin4 Runtime it is set to
None, that means STORAGE_DIR path should be the root directory.

The path formed to file was "None/filename.ext'. but it should be
'/filename.txt' which is now fixed.
Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Thu, 4 Aug 2016 16:34:54 +0100

Thanks, applied.

On Thu, Aug 4, 2016 at 1:59 PM, Surinder Kumar
<[email-masked]> wrote:
> Issue:

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company