Subject: PATCH: To update table dialog column definition

From: Murtuza Zabuawala <[email-masked]>
Date: Tue, 12 Jul 2016 11:30:02 +0530

Hi,

PFA patch to fix below issues

*1) User** cannot select a datatype without using the mouse.*

Fixed.

Remaining issue,
-----------------------
We are using Switch cell to select Not NULL & Is primary key options.
But as per Backgrid design we are not allowed to enter in edit mode
directly for BooleanCell (like we can for NumberCell) from which we are
Inherited our Switch cell, so user have to click once on this cell to go
into edit mode then only they can use keyborad to toggle the values of
switch cell.

I'll check with Ashesh if we can fix this issue.

*2) The Primary Key option in the grid cannot be toggled without opening
advanced options.*

This has been fixed already RM#1235, Once user provides column name it will
gets enable.

*3) Fields are missing from the grid: length, precision, not null.
Inherited from should not be there.*

Fixed

Please review.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Jul 2016 10:12:47 +0100

Thanks, applied with minor changes to the labelling of the switches in the grid.

On Tue, Jul 12, 2016 at 7:00 AM, Murtuza Zabuawala
<[email-masked]> wrote:
> 1) User cannot select a datatype without using the mouse.
>
> Fixed.
>
> Remaining issue,
> -----------------------
> But as per Backgrid design we are not allowed to enter in edit mode directly
> for BooleanCell (like we can for NumberCell) from which we are Inherited our
> Switch cell, so user have to click once on this cell to go into edit mode
> then only they can use keyborad to toggle the values of switch cell.
>
> 2) The Primary Key option in the grid cannot be toggled without opening
> advanced options.
>
> 3) Fields are missing from the grid: length, precision, not null. Inherited
> from should not be there.
>
> Fixed
>
>
> Please review.
>
> --
> Regards,
> Murtuza Zabuawala

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company