Subject: importlib dependency?

From: Devrim Gündüz <[email-masked]>
Date: Mon, 12 Sep 2016 16:50:44 +0300

Hi,

python-importlib is mentioned in requirements_py2.txt, but not
in requirements_py3.txt. Is that expected? Do we need importlib only in PY2?
(I'm tired of building the dependency hell...)

Thanks!

Regards,
-- 
Devrim GÜNDÜZ
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Sep 2016 15:04:44 +0100

Hi

> in requirements_py3.txt. Is that expected? Do we need importlib only in PY2?

Yes. The functionality is built into Python 3 (and I think 2.7 as
well, but not earlier).

> (I'm tired of building the dependency hell...)

:-(

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers