Subject: [pgAdmin4][patch] Keyboard accessibility for sub-node control

From: Ganesh Jaybhay <[email-masked]>
Date: Mon, 8 Jul 2019 19:13:31 +0530

Hi Hackers,

Attached is the patch for keyboard accessibility of sub-node control. It
also covers sub-node dialog forward/backward tab navigation with shortcuts.

Kindly review.

Regards,
Ganesh Jaybhay

---

From: Dave Page <[email-masked]>
Date: Tue, 9 Jul 2019 16:58:41 +0100

Hi,

What's the ticket number for this? That's a fair amount of code for a
one-line description. There are also no doc changes describing how to
navigate the sub-node control that I can see.

Also; instead of changing the repo used for backgrid, can we not
un-vendorise it?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Ganesh Jaybhay <[email-masked]>
Date: Thu, 11 Jul 2019 11:29:57 +0530

Hi Dave,

Ticket number 3919 refers to keyboard accessibility issues for sub-node
control and back grid but this patch covers only sub-node control. Should I
create new one?
I have added the screenshot having newly added shortcut and updated
keyboard shortcut rst file. Also moved the code changes from backgrid.js to
backgrid.pgadmin.js.

Please find the attached updated patch.

Regards,
Ganesh Jaybhay

---

From: Dave Page <[email-masked]>
Date: Thu, 11 Jul 2019 10:14:27 +0100

Thanks - patch applied with some doc tweaks.

No need for a new ticket!

---

From: Dave Page <[email-masked]>
Date: Thu, 11 Jul 2019 11:19:02 +0100

Hi Ganesh,

It looks like this has broken the Jasmine tests (which I admit I forgot to
run before committing). Can you fix ASAP please?

Thanks.

On Thu, Jul 11, 2019 at 10:14 AM Dave Page <[email-masked]> wrote:

>>>> Attached is the patch for keyboard accessibility of sub-node control.
>>>> It also covers sub-node dialog forward/backward tab navigation with
>>>> shortcuts.
>>>>
>>>> Kindly review.
>>>>
>>>> Regards,
>>>> Ganesh Jaybhay
>>>>
>>>
>>>
>>> --
>>> Dave Page

---

From: Ganesh Jaybhay <[email-masked]>
Date: Fri, 12 Jul 2019 00:09:56 +0530

Hi Dave,

Please find the attached patch for jasmine tests fix. Patch also includes
fixes for edit/delete cell focus on IE by Murtuza.

Regards,

Ganesh Jaybhay

---

From: Dave Page <[email-masked]>
Date: Fri, 12 Jul 2019 10:06:57 +0100

Thanks - committed as the IE fixes, with the Jasmine stuff as a bonus :-)

On Thu, Jul 11, 2019 at 7:40 PM Ganesh Jaybhay <
[email-masked]> wrote:

>> It looks like this has broken the Jasmine tests (which I admit I forgot
>> to run before committing). Can you fix ASAP please?
>>
>> Thanks.
>>