Subject: [pgAdmin][RM3174] Distinguish simple tables from tables that are inherited and from which other tables are inherited

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 17 Jun 2019 12:01:30 +0530

Hi Hackers,

Attached is the patch to change icons for table inheritance (icons by
Chethana Kumar)
Along with this, I have also fixed few other issues/icons found on the way:
1) Dependencies tab for inherited tables/foreign keys shows partial text
(#3994).
2) Dependencies tab for child partition table shows parent partition table
as Function.
3) Dependencies tab for triggers shows trigger functions as plain functions.
4) Dependents tab for partitioned table shows the child partition tables as
normal table instead for partitioned tables.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Mon, 17 Jun 2019 10:36:38 +0100

Thanks, applied.

On Mon, Jun 17, 2019 at 7:32 AM Aditya Toshniwal <
[email-masked]> wrote:

> 4) Dependents tab for partitioned table shows the child partition tables
> as normal table instead for partitioned tables.
>
> Kindly review.
>
> --
> Thanks and Regards,
> Aditya Toshniwal

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company