Subject: Fix projection of pg_type for Greenplum query

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 23 Jul 2019 10:13:00 +0200

The bug in https://redmine.postgresql.org/issues/4179 seems to be due to
pg_type being projected from but not selected, the attached patch adds a FROM
clause entry and also adds projection of typname.  This makes the query work on
5X_STABLE for me.

cheers ./daniel

---

From: Dave Page <[email-masked]>
Date: Thu, 25 Jul 2019 16:17:00 +0100

Thanks, patch applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company