Subject: [pgAdmin4][Patch]: RM1728 - Properties are not refreshing after objects are edited

From: Surinder Kumar <[email-masked]>
Date: Fri, 23 Sep 2016 12:09:42 +0530

Hi

*Issue:*
on updating node, we deselect and then again select the node updated to
refresh the panel. but it needs some delay of few milliseconds between
deselect and select to fix this issue.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 23 Sep 2016 10:14:38 +0100

Hi

On Fri, Sep 23, 2016 at 7:39 AM, Surinder Kumar
<[email-masked]> wrote:
> Issue:

This does not resolve the issue for me. I tested using a synonym to a
package on EPAS 9.5, by changing the target package name.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Fri, 23 Sep 2016 16:35:11 +0530

Hi,

Please find updated patch with changes:
1) On debugging through JS files, the issue was in synonym update method
which wasn't returning node object.
2) retrieving schema name in node.sql for creating node object in update
method.

Please review and let me know for comments.

---

From: Dave Page <[email-masked]>
Date: Fri, 23 Sep 2016 13:29:18 +0100

Thanks, applied.

---

From: Dave Page <[email-masked]>
Date: Fri, 23 Sep 2016 13:30:18 +0100

Umm, no it wasn't - sorry.

I see the same issue with Types. Can you fix that, and check all other
nodes as well please?

Thanks.

---

From: Surinder Kumar <[email-masked]>
Date: Fri, 14 Oct 2016 15:31:05 +0530

Hi

*Following are the issues fixed in nodes:*

1) If we create/update a node with non-default schema, It should return
selected schema id in return response. but default schema id is returned
every time due to which it throws error in properties panel.
Fixed in Domains, Collation, Types, Views & Table node.

2) Incorrect parent id of object node is returned from *nodes method* due
to which wrong parent id is passed while updating object and
thus node didn't get refreshed.
Fixed in FTS Configuration, FTS Parser nodes.

Also, I have kept changes of first patch which are essential to refresh
node every time. Without that patch nodes properties panel updates only
sometimes.

Please find attached patch. Please review and let me know for comments.

Thanks
Surinder Kumar

---

From: Dave Page <[email-masked]>
Date: Fri, 14 Oct 2016 20:19:17 +0100

Thanks, applied.

On Friday, October 14, 2016, Surinder Kumar <[email-masked]>
wrote:

> On Fri, Sep 23, 2016 at 6:00 PM, Dave Page <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
>> On Fri, Sep 23, 2016 at 1:29 PM, Dave Page <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> > Thanks, applied.
>> >
>> > <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> >> Hi,
>> >>
>> >> On Fri, Sep 23, 2016 at 2:44 PM, Dave Page <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> >>>
>> >>> Hi
>> >>>
>> >>> <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> >>> > Hi
>> >>> >
>> >>> > Issue:

---

From: Dave Page <[email-masked]>
Date: Sun, 16 Oct 2016 02:59:37 +0100

Hi

I just found a case where this patch is broken - if you update the comment
on a type, it looks like it tried to lookup the schema ID using the type
name, which a) isn't in the posted data so gives a 500 response, and b)
wouldn't be safe anyway, if there were types with the same name in multiple
schemas.

Actually, it looks like that's an issue when creating a type too - that is
also using an unsafe schema lookup.

Please fix this ASAP (i.e. Monday) and double check to ensure we're not
doing any more unsafe lookups like this.

Thanks.

On Friday, October 14, 2016, Dave Page <[email-masked]> wrote:

> Thanks, applied.
>
> On Friday, October 14, 2016, Surinder Kumar <surinder.kumar@enterprisedb.
> com <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
> wrote:
>
>> Hi
>>
>> 2) Incorrect parent id of object node is returned from *nodes method*
>> due to which wrong parent id is passed while updating object and

---

From: Surinder Kumar <[email-masked]>
Date: Mon, 17 Oct 2016 12:18:05 +0530

> wouldn't be safe anyway, if there were types with the same name in multiple
​I have fixed this issue. Now it will lookup the schema ID against the type
id instead of type name.​

> doing any more unsafe lookups like this.
​It looks good to me in other nodes.
Please find attached patch and review.​

>> On Friday, October 14, 2016, Surinder Kumar <
>> [email-masked]> wrote:
>>
>>> Hi
>>>

---

From: Dave Page <[email-masked]>
Date: Tue, 18 Oct 2016 11:33:32 +0100

Thanks - applied!

On Mon, Oct 17, 2016 at 7:48 AM, Surinder Kumar
<[email-masked]> wrote:
> I have fixed this issue. Now it will lookup the schema ID against the type
> id instead of type name.
>>
>>
> It looks good to me in other nodes.
>>> On Friday, October 14, 2016, Surinder Kumar
>>>> Following are the issues fixed in nodes:
>>>>
>>>> 2) Incorrect parent id of object node is returned from nodes method due

---

From: Surinder Kumar <[email-masked]>
Date: Thu, 20 Oct 2016 12:28:51 +0530

Hi,

While fixing RM1840, I found when we add new index, it doesn't add under
right parent. i.e. columns collection. because wrong parent is given in
response.
I also verified other nodes. This issue is only with index node.

Do, I need to create separate RM for this case. ?

Please find attached minor patch and review.

On Tue, Oct 18, 2016 at 4:03 PM, Dave Page <[email-masked]> wrote:

> >>>>> >>> This does not resolve the issue for me. I tested using a synonym
> to
> >>>>> >>> a

---

From: Dave Page <[email-masked]>
Date: Fri, 21 Oct 2016 12:12:50 +0100

Thanks, applied (and I dealt with the RM).