Subject: [pgAdmin4][Patch]: Wrong listing of directories in File Manager in Windows Only.

From: Surinder Kumar <[email-masked]>
Date: Mon, 5 Sep 2016 15:21:19 +0530

Hi

*Issue:*
FileManager: when Select File dialog is opened in query tool in Runtime
Mode, it was listing wrong directory. instead it should list drives such as
C:\, D:\, E:\ etc if no STORAGE_DIR path is set in config_local.py. This is
a regression of RM 1937.

*Solution:*
we do list drives, If platform is Windows and If self.dir is set to None,
but self.dir is set to empty string inside __init__ constructor. This is
the reason it wasn't listing drives.
I have taken care it in this patch and tested it for following platforms:
Windows,
Ubuntu and
Mac.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Mon, 5 Sep 2016 17:07:32 +0100

Thanks, applied.

On Mon, Sep 5, 2016 at 10:51 AM, Surinder Kumar
<[email-masked]> wrote:
> Issue:
> Solution:
> but self.dir is set to empty string inside __init__ constructor. This is the
> reason it wasn't listing drives.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company