Subject: PATCH: To fix issue in synonym node (pgAdmin4)

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 5 Oct 2016 14:23:26 +0530

Hi,

PFA patch to fix the issue in synonym node, where it was not horning parent
node while creating in different node, issue was that we were not sending
node properly.
RM#1611

Please review.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 5 Oct 2016 13:08:06 +0100

Hi

> node while creating in different node, issue was that we were not sending

That doesn't seem like a reliable way to get the correct parent ID -
what if there are multiple synonyms in different schemas but with the
same name?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 5 Oct 2016 17:58:11 +0530

Hi Dave,

PFA updated patch, Added schema filter in sql.
Please review.

---

From: Dave Page <[email-masked]>
Date: Wed, 5 Oct 2016 14:23:46 +0100

Hi

I created a synonym from within the "dave" schema, but selected
"public" (which wasn't expanded), and it placed the synonym as a
direct child of "public". See the attached screenshot.

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 6 Oct 2016 15:12:36 +0530

Hi Dave,

The issue you mentioned is different issue and not related to synonyms node.
I will create separate ticket & work on it mean while you can commit
changes for RM#1611

---

From: Dave Page <[email-masked]>
Date: Fri, 7 Oct 2016 12:08:28 +0100

Thanks, patch applied.

On Thu, Oct 6, 2016 at 10:42 AM, Murtuza Zabuawala
<[email-masked]> wrote:
> I will create separate ticket & work on it mean while you can commit changes
> for RM#1611
>
> --
> Regards,
> Murtuza Zabuawala