Subject: [pgAdmin4] Query Tools result paginate control labels

From: Seçkin Alan <[email-masked]>
Date: Fri, 15 Apr 2016 21:41:54 +0300

Hi,

Backgrid js default control label is 《,
it looks bad.
now it looks like this
<< < 1 > >>
​

-- 
Seçkin ALAN
http://sckn.org
diff --git a/web/pgadmin/tools/sqleditor/templates/sqleditor/js/sqleditor.js b/web/pgadmin/tools/sqleditor/templates/sqleditor/js/sqleditor.js
index 463ee45..f0fed4d 100644
--- a/web/pgadmin/tools/sqleditor/templates/sqleditor/js/sqleditor.js
+++ b/web/pgadmin/tools/sqleditor/templates/sqleditor/js/sqleditor.js
@@ -450,6 +450,13 @@ define(
           }),
           paginator = self.paginator = new Backgrid.Extension.Paginator({
             goBackFirstOnSort: false,
+
+                                               fastForwardHandleLabels: {
+                                                       first: "<<",
+                                                       prev: "<",
+                                                       next: ">",
+                                                       last: ">>"
+                                               },
             collection: collection
           }),
           clientSideFilter = self.clientSideFilter = new Backgrid.Extension.ClientSideFilter({

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Sat, 16 Apr 2016 09:48:37 +0100

Hi,

This doesn't seem to make any difference to me - I've tried the normal hard
reload etc. and confirmed your code is reaching the browser by checking the
source in the dev tools.

Am I missing something?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Sat, 16 Apr 2016 23:54:37 +0100

On Saturday, April 16, 2016, Seçkin Alan <[email-masked]> wrote:

> Hi Dave,
>
> You're right.
> My fault is try on one browser.
>
> I tried in some browsers on GNU/Linux
> Linux seckin-home 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u4
> (2016-02-29) x86_64 GNU/Linux
>
> Repository Installed Iceweasel - OK
> Repository Installed Chromium - OK
> Self Install Google Chrome - NOT OK.
> I do not know for the moment is such.
>
> I add screenshots.
>

Hmm, Chrome is my primary browser (albeit on Mac) - and it's fine there.
Missing font perhaps?

>
> On Sat, Apr 16, 2016 at 11:48 AM, Dave Page <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
>>
>>
>> On Friday, April 15, 2016, Seçkin Alan <[email-masked]> wrote:
>>
>>> Hi,
>>>
>> This doesn't seem to make any difference to me - I've tried the normal
>> hard reload etc. and confirmed your code is reaching the browser by
>> checking the source in the dev tools.
>>
>> Am I missing something?
>>
>>
>> --
>> Dave Page