Subject: pgAdmin4 v4.11 candidate builds

From: Akshay Joshi <[email-masked]>
Date: Tue, 23 Jul 2019 11:01:52 +0530

Hi All,

pgAdmin4 v4.11 candidate builds and source can be found at
https://developer.pgadmin.org/builds/2019-07-23-1/

Fahar, can you please verify it for release on Thursday.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Fahar Abbas <[email-masked]>
Date: Tue, 23 Jul 2019 10:36:58 +0500

Thanks for sharing candidate builds.

-- 
Fahar Abbas
QMG
EnterpriseDB Corporation
Phone Office: +92-51-835-8874
Phone Direct: +92-51-8466803
Mobile: +92-333-5409707
Skype ID: *live:fahar.abbas*
Website: www.enterprisedb.com

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Jul 2019 14:48:43 +0100

Hi Akshay,

> https://developer.pgadmin.org/builds/2019-07-23-1/

Where can I get some info about html_theme parameter change? I used to change
it from classic to default in the RPMs, and now it is pgadmin4 by default. The
PDF doc does not include any info about this.

Cheers,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 23 Jul 2019 21:58:18 +0530

> PDF doc does not include any info about this.
Because - pgAdmin4 has its own documentation theme. :-)

-- Ashesh

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Jul 2019 22:41:28 +0100

Hi Ashesh,

> Because - pgAdmin4 has its own documentation theme. :-)

Thanks, but this does not answer my question. This theme (like the previous
"classic" theme) breaks RHEL 7 builds:
 
Running Sphinx v1.1.3
loading pickled environment... not yet created

Theme error:
no theme named 'classic' found, inherited by 'pgadmin4'
make[2]: *** [html] Error 1
make[2]: Leaving directory `/home/pgsql/git/pgrpms/rpm/redhat/master/pgadmin4/master/pgadmin4-4.11/docs/en_US'
make[1]: *** [docs] Error 2
make[1]: Leaving directory `/home/pgsql/git/pgrpms/rpm/redhat/master/pgadmin4/master/pgadmin4-4.11'
error: Bad exit status from /var/tmp/rpm-tmp.Afb3Zm (%build)

So, I updated the patch, and used the default theme again in 4.11 RPMs.

Cheers,

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Jul 2019 22:54:01 +0100

> https://developer.pgadmin.org/builds/2019-07-23-1/

Just hit an issue on RHEL 7 (Python 2.7.5) :

+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
Bytecompiling .py files below /var/lib/pgsql/rpm11testing/BUILDROOT/pgadmin4-4.11-1.rhel7.x86_64/usr/lib/python2.7 using /usr/bin/python2.7
Compiling /var/lib/pgsql/rpm11testing/BUILDROOT/pgadmin4-4.11-1.rhel7.x86_64/usr/lib/python2.7/site-packages/pgadmin4-web/pgadmin/feature_tests/query_tool_journey_test.py ...
  File "/usr/lib/python2.7/site-packages/pgadmin4-web/pgadmin/feature_tests/query_tool_journey_test.py", line 57
    print("Copy rows...", file=sys.stderr, end="")
                              ^
SyntaxError: invalid syntax

Any ideas?

Regards,

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2019 10:48:14 +0530

Hi Devrim

On Wed, Jul 24, 2019 at 3:24 AM Devrim Gündüz <[email-masked]> wrote:

> Bytecompiling .py files below
> /var/lib/pgsql/rpm11testing/BUILDROOT/pgadmin4-4.11-1.rhel7.x86_64/usr/lib/python2.7
> using /usr/bin/python2.7
> Compiling
> /var/lib/pgsql/rpm11testing/BUILDROOT/pgadmin4-4.11-1.rhel7.x86_64/usr/lib/python2.7/site-packages/pgadmin4-web/pgadmin/feature_tests/query_tool_journey_test.py
> ...
>   File
> "/usr/lib/python2.7/site-packages/pgadmin4-web/pgadmin/feature_tests/query_tool_journey_test.py",
> line 57

   Feature test are not stable yet, so we will have to remove that from our
build process.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 24 Jul 2019 08:32:43 +0100

Hi,

>    Feature test are not stable yet, so we will have to remove that from our

How? Will you re-wrap 4.11? If not, can you please send me a patch so that I
can apply it to the RPMs?

Thanks!

Cheers,

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2019 13:08:48 +0530

Hi Devrim

> can apply it to the RPMs?

   No, I'll not re-wrap 4.11. I am not much aware of the RPM's, but I think
you will need to change the spec file and add "--exclude feature_tests"
parameter to the command for regression test.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Dave Page <[email-masked]>
Date: Wed, 24 Jul 2019 08:51:58 +0100

On Wed, Jul 24, 2019 at 8:39 AM Akshay Joshi <[email-masked]>
wrote:

>    No, I'll not re-wrap 4.11. I am not much aware of the RPM's, but I
> think you will need to change the spec file and add "--exclude
> feature_tests" parameter to the command for regression test.
>

He's not running the tests, it's the RPM build precompiling the bytecode
automatically.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Dave Page <[email-masked]>
Date: Wed, 24 Jul 2019 08:53:46 +0100

On Tue, Jul 23, 2019 at 10:41 PM Devrim Gündüz <[email-masked]> wrote:

> make[2]: Leaving directory
> `/home/pgsql/git/pgrpms/rpm/redhat/master/pgadmin4/master/pgadmin4-4.11/docs/en_US'
> make[1]: Leaving directory
> `/home/pgsql/git/pgrpms/rpm/redhat/master/pgadmin4/master/pgadmin4-4.11'

Stupid CentOS/RHEL...

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 24 Jul 2019 08:55:11 +0100

Hi Akshay,

> parameter to the command for regression test.

I don't run regression tests in the spec file:

https://git.postgresql.org/gitweb/?p=pgrpms.git;a=blob;f=rpm/redhat/master/pgadmin4/master/pgadmin4.spec;h=576a07420ecb250dfdc57291f1c294cb06c963f9;hb=HEAD

What I basically do is:
* cd runtime; qmake -o Makefile pgAdmin4.pro; cd ..
* build docs
* Manually install the files.
* Create config_distro.py file

Cheers,

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2019 14:45:00 +0530

Hi Devrim

We have figure out the problem with the syntax print("Copy rows...",
file=sys.stderr, end="") with Python 2.7.
Attached is the patch please apply, test it and let me know.

On Wed, Jul 24, 2019 at 1:25 PM Devrim Gündüz <[email-masked]> wrote:

> think

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 24 Jul 2019 14:56:28 +0100

Hi Akshay,

> Attached is the patch please apply, test it and let me know.

Great, it worked!

Will this patch be included in 4.12?

Cheers,

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Jul 2019 19:39:59 +0530

> Will this patch be included in 4.12?

    @Dave, Can you please comment on this. If we include this patch in
4.11, I'll have to rewrap the candidate build.

---

From: Dave Page <[email-masked]>
Date: Wed, 24 Jul 2019 15:14:20 +0100

> 4.11, I'll have to rewrap the candidate build.

Commit for 4.12 please. Thanks.

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Fahar Abbas <[email-masked]>
Date: Thu, 25 Jul 2019 16:59:28 +0500

Hi,

One round of Smoke/ Functional Sanity and Detail(level 1) testing has been
completed for pgadmin4 4.11.

Can we  please publish pgadmin4 4.11?

Kind Regards

On Wed, Jul 24, 2019 at 7:14 PM Dave Page <[email-masked]>
wrote:

>
>
> On Wed, Jul 24, 2019 at 3:10 PM Akshay Joshi <
> [email-masked]> wrote:
>
>>
>>