Subject: [pgAdmin4][Patch]: RM1478 - Paste event is not working in Query tool

From: Surinder Kumar <[email-masked]>
Date: Wed, 14 Sep 2016 13:53:13 +0530

Hi

*Issue:*
On debugging deeply into the code mirror JS library, I found that* Ctrl-V
event *is mapped for *"goPageDown" *which is the reason paste not working
in Mac Runtime.

I have removed this mapping temporary from Code-mirror key map object once
code mirror JS library is loaded.

In Mac Runtime, Paste event will work on *Cmd-V.*

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Sep 2016 11:17:58 +0100

Awesome job tracking this one down!

Thanks, patch applied.

On Wed, Sep 14, 2016 at 9:23 AM, Surinder Kumar
<[email-masked]> wrote:
> Hi
>
> Issue:
> On debugging deeply into the code mirror JS library, I found that Ctrl-V
> event is mapped for "goPageDown" which is the reason paste not working in
> Mac Runtime.
>
> In Mac Runtime, Paste event will work on Cmd-V.
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 14 Sep 2016 15:49:46 +0530

> Awesome job tracking this one down!
​Thanks.​