Subject: RE-SQL test patch for extension node

From: Nagesh Dhope <[email-masked]>
Date: Fri, 5 Jul 2019 19:44:56 +0530

Hi Hackers,
Please review attached patch for RE-SQL test cases for *extension* node.

Thanks,
Nagesh Dhope

---

From: Dave Page <[email-masked]>
Date: Mon, 8 Jul 2019 09:33:16 +0100

Hi

> Please review attached patch for RE-SQL test cases for *extension* node.

Unfortunately this fails on PostgreSQL 12 as the deprecated timetravel
contrib module has finally been removed.

Perhaps use sslinfo? That seems less likely to go away anytime soon.

Thanks.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Nagesh Dhope <[email-masked]>
Date: Tue, 9 Jul 2019 10:46:35 +0530

Hi Dave,

Please find updated patch with *sslinfo.*

---

From: Dave Page <[email-masked]>
Date: Tue, 9 Jul 2019 12:24:06 +0100

Hi

I have a sneaking suspicion that the work Akshay and Khushboo have been
doing might have broken this :-(

Create Extension with all options..............OK
 ... 2019-07-09 12:22:55,268: ERROR flask.app: Failed to execute query
(execute_dict) for the server #5- DB:test_db_d08e5 (Query-id: 1400245):
Error Message:ERROR:  schema "test_extension_schema" does not exist

Alter Extension version..............FAIL
Traceback (most recent call last):
  File
"/Users/dpage/git/pgadmin4/web/regression/re_sql/tests/test_resql.py", line
230, in execute_test_case
    self.assertEquals(response.status_code, 200)
  File
"/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/unittest/case.py",
line 1338, in deprecated_func
    return original_func(*args, **kwargs)
  File
"/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/unittest/case.py",
line 839, in assertEqual
    assertion_func(first, second, msg=msg)
  File
"/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/unittest/case.py",
line 832, in _baseAssertEqual
    raise self.failureException(msg)
AssertionError: 500 != 200

On Tue, Jul 9, 2019 at 6:16 AM Nagesh Dhope <[email-masked]>
wrote:

>> On Fri, Jul 5, 2019 at 5:16 PM Nagesh Dhope <
>> [email-masked]> wrote:
>>
>>> Hi Hackers,

---

From: Nagesh Dhope <[email-masked]>
Date: Tue, 9 Jul 2019 17:39:21 +0530

Hi Dave,

> doing might have broken this :-(

Yup, earlier we were able to create a  schema if not exists while
running *alter
*test cases. As this capability is remove alter test case for extension was
failing.
I have fixed the test case, PFA updated patch.

---

From: Dave Page <[email-masked]>
Date: Tue, 9 Jul 2019 13:23:35 +0100

Thanks, applied!

On Tue, Jul 9, 2019 at 1:09 PM Nagesh Dhope <[email-masked]>
wrote:

> Yup, earlier we were able to create a  schema if not exists while running *alter
> *test cases. As this capability is remove alter test case for extension
> was failing.
>> On Tue, Jul 9, 2019 at 6:16 AM Nagesh Dhope <

---

From: Nagesh Dhope <[email-masked]>
Date: Thu, 11 Jul 2019 11:54:50 +0530

Please ignore this patch. Sending updated on new thread

On Thu, Jul 11, 2019 at 11:40 AM Nagesh Dhope <[email-masked]>
wrote:

> Fixed failing extension resql test cases on PG 9.4 and PG 9.5.
> PFA updated patch.
>
> On Tue, Jul 9, 2019 at 5:53 PM Dave Page <[email-masked]> wrote:
>
>> Thanks, applied!
>>
>> On Tue, Jul 9, 2019 at 1:09 PM Nagesh Dhope <
>>> running *alter *test cases. As this capability is remove alter test
>>> case for extension was failing.
>>>>>> Unfortunately this fails on PostgreSQL 12 as the deprecated
>>>>>> timetravel contrib module has finally been removed.
>>>>>>