Subject: [pgAdmin4][Patch]: Select2 control destroy issue [Minor fix]

From: Surinder Kumar <[email-masked]>
Date: Fri, 14 Oct 2016 15:39:02 +0530

Hi

While clicking on Select2 control, it tries to destroy the control and thus
it doesn't get this object sometimes and throws error.

It should attempt to destroy the select2 object only if this object is not
undefined.
Adds proper check to handle the case.

Please find minor patch and review.

Thanks
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 14 Oct 2016 20:20:43 +0100

Thanks, applied.

On Friday, October 14, 2016, Surinder Kumar <[email-masked]>
wrote:

> Hi
>
> While clicking on Select2 control, it tries to destroy the control and
> thus it doesn't get this object sometimes and throws error.
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Fri, 21 Oct 2016 20:25:29 +0530

​I missed to add the check "destroy only if select2 has destroy property'.
in previous patch.
It was reproducible when I select access method of exclusion constraint
from combo box.

Please find attached patch and review.

On Sat, Oct 15, 2016 at 12:50 AM, Dave Page <[email-masked]> wrote:

> Thanks, applied.
>
>
> On Friday, October 14, 2016, Surinder Kumar <surinder.kumar@enterprisedb.
> com> wrote:
>
>> Hi
>>
>> It should attempt to destroy the select2 object only if this object is
>> not undefined.

---

From: Dave Page <[email-masked]>
Date: Fri, 21 Oct 2016 16:16:20 +0100

Thanks, applied.

On Fri, Oct 21, 2016 at 3:55 PM, Surinder Kumar
<[email-masked]> wrote:
> I missed to add the check "destroy only if select2 has destroy property'. in
> previous patch.
> It was reproducible when I select access method of exclusion constraint from
> combo box.
>
>> On Friday, October 14, 2016, Surinder Kumar
>> <[email-masked]> wrote:
>>>
>>> Hi
>>>