Subject: [pgAdmin4][Patch]: Slickgrid loading issue in Query tool

From: Surinder Kumar <[email-masked]>
Date: Mon, 19 Sep 2016 19:28:49 +0530

Hi

*Issue:*
Slick-grid libraries loads when an instance of query tool is opened. But
sometimes it throws exception "jQuery is not defined" and it doesn't opens
up.

*Solution:*
As per my understanding, In *datagrid/index.html* file, we set the order of
loading libraries such as
*require(['jquery', 'pgadmin', 'pgadmin.sqleditor']) *
but it still loads *pgadmin.sqleditor.js* file before *jQuery* for unknown
reason.

To fix this, we load *pgadmin.sqleditor.js* file using *require([],
function(){}) *module loader which ensures that the code within
*function(){}* will be executed when pgadmin.sqleditor.js is loaded.

Please find attache patch.
This issue is fixed by *Ashesh Vashi*.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Mon, 19 Sep 2016 17:09:19 +0100

Thanks, applied.

On Mon, Sep 19, 2016 at 2:58 PM, Surinder Kumar
<[email-masked]> wrote:
> Issue:
> Solution:
> As per my understanding, In datagrid/index.html file, we set the order of
> require(['jquery', 'pgadmin', 'pgadmin.sqleditor'])
> but it still loads pgadmin.sqleditor.js file before jQuery for unknown
> reason.
>
> To fix this, we load pgadmin.sqleditor.js file using require([],
> function(){}) module loader which ensures that the code within function(){}
> will be executed when pgadmin.sqleditor.js is loaded.
>
> This issue is fixed by Ashesh Vashi.
>
> Thanks,
> Surinder Kumar
>
>
> --

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company