Subject: [pgAdmin][RM4451]Cannot construct SQL script for composite type having only one field variable

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 1 Nov 2019 15:23:29 +0530

Hi Hackers,

pgAdmin allows to create composite type only with 2 or more members.
Attached is the patch to remove the restriction as PostgreSQL allows zero
or more and fix the issue where SQL is not generated for types having less
than 2 members.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Fri, 1 Nov 2019 15:22:40 +0000

Thanks, patch applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company