Subject: pgAdminIV : Regression tests code cleanup

From: Navnath Gadakh <[email-masked]>
Date: Fri, 7 Oct 2016 18:13:19 +0530

Hi Dave,
    Please find the patch of test framework, which contains
1. Code changes (due to drop objects functionality).
2. Quoting for database names in drop databases.
3. Code changes for import errors for pickle_path and advanced_config
variables.

*Run test suite by this command:*
  python runtests.py

Thanks.
-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 7 Oct 2016 14:01:47 +0100

Awesome - the test suite just found it's first bug! There was a code
path that referenced a variable that hadn't been defined, added in a
patch that I committed earlier without spotting the issue. The
associated tests failed, and I pretty quickly spotted (and fixed) the
bug as a result :-D

Patch applied!

On Fri, Oct 7, 2016 at 1:43 PM, Navnath Gadakh
<[email-masked]> wrote:
> Run test suite by this command:
>   python runtests.py
>
> Thanks.
> --
> Regards,
> Navnath Gadakh
>
> EnterpriseDB Corporation

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

---

From: Navnath Gadakh <[email-masked]>
Date: Fri, 7 Oct 2016 18:38:22 +0530

Thanks Dave.

-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation