Subject: [patch][pgAdmin4] Windows error - The application server could not be contacted occasionally

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 1 Jan 2019 15:54:34 +0530

Hi Hackers,

Some of the windows users are facing the error as "The application server could
not be contacted" while starting pgAdmin4. The startup logs had nothing.
Just that the application timed out.
I was able to simulate the issue for sometime when I started my windows
machine, but later it did not throw any error and worked fine.
It turned out that due to the slowness of the Windows OS initially the
application took time to setup which was longer than the app start timeout
- 30secs and so, timed out.
In the attached patch, I have increased the timeout to 90secs (difficult to
figure out the standard timeout). Plus, I have changed the messages at
intervals when the app is starting so that it does not look stuck.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Dave Page <[email-masked]>
Date: Wed, 2 Jan 2019 11:57:48 +0000

Thanks, applied.

On Tue, Jan 1, 2019 at 10:24 AM Aditya Toshniwal
<[email-masked]> wrote:
>
> Hi Hackers,
>
> Some of the windows users are facing the error as "The application server could not be contacted" while starting pgAdmin4. The startup logs had nothing. Just that the application timed out.
> I was able to simulate the issue for sometime when I started my windows machine, but later it did not throw any error and worked fine.
> It turned out that due to the slowness of the Windows OS initially the application took time to setup which was longer than the app start timeout - 30secs and so, timed out.
> In the attached patch, I have increased the timeout to 90secs (difficult to figure out the standard timeout). Plus, I have changed the messages at intervals when the app is starting so that it does not look stuck.
>
> Kindly review.
>
> --
> Thanks and Regards,
> Aditya Toshniwal

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company