Subject: Required inputs in issue #6138

From: Nikhil Mohite <[email-masked]>
Date: Wed, 14 Jun 2023 18:13:38 +0530

Hi Hacker,

I am currently working on issue #6138
<https://github.com/pgadmin-org/pgadmin4/issues/6138>, which was fixed
earlier but the fix was not correct so working on it again.
Steps to reproduce the issue:
1. Open *View/Edit Data *for *table1*
2. Open the PSQL tool delete the same *table1 *and recreates the same name
table *table1* and try to re-execute the query from the already opened
*View/Edit
data *panel.
3. pgAdmin throws an error in the Messages tab *List index out of
range *(pgAdmin
query to get table columns from Postgres based on *table oid* which was
deleted and the return result is empty which is not handled in pgAdmin)*.*

Approach to fix this issue:
1. If the user re-executes the query from already opened *View/Edit data* we
should fetch the table details by using *schema and table name (not using
table oid)* and show the newly created table records in the result.
(This will only fix an issue with *View/Edit Data *however if the user
switches to properties or some other panel it user will still get an error
notification with content *"could not find the specified table."*)

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Senior Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Jun 2023 10:40:43 +0100

On Wed, 14 Jun 2023 at 13:43, Nikhil Mohite <[email-masked]>
wrote:

> 2. Open the PSQL tool delete the same *table1 *and recreates the same
> name table *table1* and try to re-execute the query from the
> already opened *View/Edit data *panel.
> 3. pgAdmin throws an error in the Messages tab *List index out of range *(pgAdmin

I think this is fine. The View/Edit data window shows the query with
table/schema name after all, so the user should expect it to work.

-- 
Dave Page
Blog: https://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: https://www.enterprisedb.com

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 15 Jun 2023 15:30:59 +0530

On Thu, Jun 15, 2023 at 3:11 PM Dave Page <[email-masked]> wrote:

>
>
> On Wed, 14 Jun 2023 at 13:43, Nikhil Mohite <
> [email-masked]> wrote:
>
>> Hi Hacker,
>>
>> should fetch the table details by using *schema and table name (not
>> using table oid)* and show the newly created table records in the result.
> The object for which the user has opened the View data panel is completely
changed. So as per me, it should raise the error object doesn't exist.
The table name is the same, but it is a different object, and when we
initialise the panel, we consider that object.

--