Subject: [pgAdmin4][Patch] - RM #4333 - Add support for function selectivity.

From: Khushboo Vashi <[email-masked]>
Date: Fri, 19 Jul 2019 14:24:06 +0530

Hi,

Please find the attached patch for the RM #4333 - [PG v12] Add support for
function selectivity.

The patch includes:
- Support Function implementation for PG/EPAS 12
- Documentation updates
- API Test cases

Thanks,
Khushboo

---

From: Dave Page <[email-masked]>
Date: Mon, 22 Jul 2019 09:37:00 +0100

Hi

In the Trigger and Type dialogues when selecting a function we give a combo
box listing all the functions in the database that match the required
signature. Can't we do this here as well?

On Fri, Jul 19, 2019 at 9:54 AM Khushboo Vashi <
[email-masked]> wrote:

> Hi,
>
> Please find the attached patch for the RM #4333 - [PG v12] Add support
> for function selectivity.
>
> The patch includes:

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 22 Jul 2019 14:29:32 +0530

On Mon, Jul 22, 2019 at 2:07 PM Dave Page <[email-masked]> wrote:

> Hi
>
> In the Trigger and Type dialogues when selecting a function we give a
> combo box listing all the functions in the database that match the required
Support function should have specific arguments and return type (i.,e.
internal), and the user needs to write the code for that function in the C.
So, what should we consider here?

---

From: Dave Page <[email-masked]>
Date: Mon, 22 Jul 2019 10:41:00 +0100

> So, what should we consider here?

Not sure what you're asking. I suggest we list all functions that match the
required signature and are written in C, much as we do elsewhere.

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 23 Jul 2019 11:05:31 +0530

Hi Dave,

Please find the attached updated patch.

On Mon, Jul 22, 2019 at 2:07 PM Dave Page <[email-masked]> wrote:

> Done.

Thanks,
Khushboo

---

From: Dave Page <[email-masked]>
Date: Thu, 25 Jul 2019 16:10:48 +0100

Thanks, applied!