Subject: pgAdmin IV : Unittest modular patch (Domains and Tables nodes)

From: Navnath Gadakh <[email-masked]>
Date: Tue, 30 Aug 2016 17:32:50 +0530

Hi Dave,
       Please find the patch API unit test cases for Domain & Tables Nodes.

This patch also includes code to drop the all objects(like database, roles,
tablespace & server) created during the test suite run.

*To run the test suite for domain node:*
 python regression/runtests.py --pkg
browser.server_groups.servers.databases.schemas.domains

*To run the test suite for tables node:*
  python regression/runtests.py --pkg
browser.server_groups.servers.databases.schemas.tables

*To run the test suite for all nodes *(Comment the all test code in
'synonyms' node i.e. Code under 'tests' directory as its partially
completed):
  python regression/runtests.py

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Thu, 1 Sep 2016 11:27:51 +0100

Per my earlier email to Priyanka, I'm not going to commit any more test
cases until the existing issues are resolved and the enhanced summary and
object cleanup work is complete, otherwise it's just taking too much time
unnecessarily.

Please re-test and resubmit this patch once that work is complete.

Thanks.

On Tue, Aug 30, 2016 at 1:02 PM, Navnath Gadakh <
[email-masked]> wrote:

> This patch also includes code to drop the all objects(like database,
> roles, tablespace & server) created during the test suite run.
>
>  python regression/runtests.py --pkg browser.server_groups.servers.
> databases.schemas.domains
>
>
>   python regression/runtests.py --pkg browser.server_
> groups.servers.databases.schemas.tables
>

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

---

From: Navnath Gadakh <[email-masked]>
Date: Thu, 1 Sep 2016 16:42:36 +0530

Hello Dave,
    Object cleanup work is completed in above patch. I am working on enhanced
summary work, once that's complete I will send the revised patch.

Thanks!

On Thu, Sep 1, 2016 at 3:57 PM, Dave Page <[email-masked]>
wrote:

>>   python regression/runtests.py --pkg browser.server_groups.
>> servers.databases.schemas.tables
>>

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878

---

From: Dave Page <[email-masked]>
Date: Thu, 1 Sep 2016 12:14:08 +0100

Hi

Please separate the cleanup from the new tests. Each patch should have just
one feature/focus/fix.

Thanks.

---

From: Navnath Gadakh <[email-masked]>
Date: Thu, 1 Sep 2016 16:51:37 +0530

Sure.

On Thu, Sep 1, 2016 at 4:44 PM, Dave Page <[email-masked]>
wrote:

> Hi
>
> Please separate the cleanup from the new tests. Each patch should have
> just one feature/focus/fix.
>
> Thanks.
>

-- 
Thanks,
Navnath Gadakh
Software Engineer
EnterpriseDB Corporation
Mobile: +91 9975389878