Subject: [pgadmin4][Patch]: Feature #2686 Property to switch lower/upper case auto completion

From: Akshay Joshi <[email-masked]>
Date: Thu, 14 Jun 2018 13:11:42 +0530

Hi Hackers,

Attached is the patch for the Feature #2686 Property to switch lower/upper
case auto completion. I have added new preferences settings "Keywords in
uppercase" if it is set to True then all the keywords are shown in upper
case in auto completion.

I have also implemented the second request in the RM to change the selected
text to upper/lower case. For that I have added new keyboard shortcut
"Toggle case of selected text" in preferences dialog. Default key is "Ctrl
+ Shift + u".

Please review it.
-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Thu, 14 Jun 2018 08:44:18 +0100

Hi

On Thu, Jun 14, 2018 at 8:41 AM, Akshay Joshi <[email-masked]
> wrote:

> I have also implemented the second request in the RM to change the
> selected text to upper/lower case. For that I have added new keyboard
> shortcut "Toggle case of selected text" in preferences dialog. Default
> key is "Ctrl + Shift + u".
>
> Please review it.
>

I don't see any doc updates in the patch - seems like that was forgotten?

Any opportunities to re-factor the code in that area into more testable
functions?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 14 Jun 2018 14:36:12 +0530

On Thu, Jun 14, 2018 at 1:14 PM, Dave Page <[email-masked]> wrote:

> Hi
>
> On Thu, Jun 14, 2018 at 8:41 AM, Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>
>> Attached is the patch for the Feature #2686 Property to switch
>> lower/upper case auto completion. I have added new preferences settings
>> "Keywords in uppercase" if it is set to True then all the keywords are
>> shown in upper case in auto completion.
>>

    You mean to say ".rst" files? If yes, then sorry I forgot to update
that. Will do it and send the modified patch.

> Any opportunities to re-factor the code in that area into more testable

    I have modified the files which are already re-factored. I haven't seen
any logic that can be re-factored.

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Thu, 14 Jun 2018 10:18:31 +0100

> that. Will do it and send the modified patch.

Yes (and any screenshots). Thanks.

>     I have modified the files which are already re-factored. I haven't
> seen any logic that can be re-factored.
>

Great, thanks.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 14 Jun 2018 15:04:21 +0530

Hi

> Yes (and any screenshots). Thanks.

    Done. Attached is the updated patch.

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Fri, 15 Jun 2018 10:19:05 +0100

Thanks, applied.

On Thu, Jun 14, 2018 at 10:34 AM, Akshay Joshi <
[email-masked]> wrote:

>>>>> shortcut "Toggle case of selected text" in preferences dialog.
>>>>> Default key is "Ctrl + Shift + u".
>>>>>
>>>>> Please review it.
>>>>>
>>>>