Subject: RM-4232- Change what is shown by default in tab titles: Implementation suggestion.

From: Nikhil Mohite <[email-masked]>
Date: Thu, 8 Oct 2020 11:17:36 +0530

Hi Team,

Regarding feature RM-4232 <https://redmine.postgresql.org/issues/4232>,
Change what is shown by default in tab titles,

I had a discussion with Akshay based on that I have added new options in
preferences for the query tool/View-Edit and Debugger.
1. Query tool and View/Edit:
Added 2 options (placeholders) under display settings of Query Tool.
default it is set to what we are currently using, If the user updates the
placeholders we will show the tab titles accordingly.

2. Debugger:
Added tab title place holder in display settings of the debugger.
default we are showing only "Debugger" as tab title.

1. If the user added any string with a placeholder that string will get
a display in the tab title along with a placeholder.
2. Tooltip for the tabs will be the same as the placeholders that the user
provided in the preferences.

Questions:
1. For scripts we are showing the same title as the Query Tool, do we need
a different placeholder for it or we can reuse the Query Tool placeholder
for it?
    (If we need to add a separate placeholder for scripts, where will be
the right place to put it in the preferences?)
2. Do we need to provide a placeholder for Debugger, as we are showing only
"Debugger" in the title.

Any suggestions or anything I have missed in this please let me know.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Dave Page <[email-masked]>
Date: Thu, 8 Oct 2020 09:41:32 +0100

Hi

> placeholders we will show the tab titles accordingly.

OK.

> provided in the preferences.

Currently the tooltips are different iirc, as they sometimes have longer
strings. Maybe we should allow them to be customised in the same way?

> the right place to put it in the preferences?)

No, scripts are just an entry point to the query tool.

> 2. Do we need to provide a placeholder for Debugger, as we are showing
> only "Debugger" in the title.
>

I think we should - and that does seem like one case where we should change
the default to be the function name or similar.

> Any suggestions or anything I have missed in this please let me know.

The Help text on the Preferences should list the placeholders the user can
use (I don't think there's any point in stating what the default is). I
would also suggest that setting the value to an empty string should cause
it to return to the default (so when the preferences are reopened, the
default value is shown, and not an empty string).

Thanks!

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

---

From: Nikhil Mohite <[email-masked]>
Date: Thu, 8 Oct 2020 15:04:33 +0530

Hi Dave,

On Thu, Oct 8, 2020 at 2:11 PM Dave Page <[email-masked]> wrote:

> Hi
>
> On Thu, Oct 8, 2020 at 6:48 AM Nikhil Mohite <
> [email-masked]> wrote:
>
>> Hi Team,
>>
>> 2. Tooltip for the tabs will be the same as the placeholders that
>> the user provided in the preferences.
>>
>

    We can provide separate placeholders for tooltips, but currently, we
are just adding the "Query Tool - " or "View/Edit Data - "  prefix in the
tooltip.
    e.g: ("Query Tool - TestDB/postgres@postgres-12") the remaining string
is similar to the title string.

>
>>
>> Questions:
>> 1. For scripts we are showing the same title as the Query Tool, do we
>> need a different placeholder for it or we can reuse the Query Tool
>> placeholder for it?
> I think we should - and that does seem like one case where we should
> change the default to be the function name or similar.
>
>
>>
Regards,
Nikhil Mohite.

---

From: Dave Page <[email-masked]>
Date: Thu, 8 Oct 2020 10:39:06 +0100

On Thu, Oct 8, 2020 at 10:34 AM Nikhil Mohite <
[email-masked]> wrote:

>>> default it is set to what we are currently using, If the user updates
>>> the placeholders we will show the tab titles accordingly.
>>>
>>
>> OK.
>>
>>
>>>
>>> 2. Debugger:
>     e.g: ("Query Tool - TestDB/postgres@postgres-12") the remaining
> string is similar to the title string.
>

OK, let's leave that as-is then.

Thanks!

>> The Help text on the Preferences should list the placeholders the user
>> can use (I don't think there's any point in stating what the default is). I