Subject: [pgAdmin4][PATCH] To fix the issue in procedure debugging in EPAS

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 5 Jun 2017 12:43:32 +0530

Hi,

PFA patch to fix the issue where debugger module is not throwing proper
error for unsupported argument mode type in procedure.
RM#1466

@Neel,
Can you please do quick review of this patch?

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company
diff --git a/web/pgadmin/tools/debugger/__init__.py b/web/pgadmin/tools/debugger/__init__.py
index 2c0dbc4..79e5eae 100644
--- a/web/pgadmin/tools/debugger/__init__.py
+++ b/web/pgadmin/tools/debugger/__init__.py
@@ -197,6 +197,15 @@ def init_function(node_type, sid, did, scid, fid, trid=None):
         elif ppas_server and r_set['rows'][0]['prosrc'].lstrip().startswith('$__EDBwrapped__$'):
             ret_status = False
             msg = gettext("EDB Advanced Server wrapped functions cannot be debugged.")
+        # We cannot debug if PPAS and argument mode is VARIADIC
+        elif ppas_server and r_set['rows'][0]['lanname'] == 'edbspl' and \
+                r_set['rows'][0]['proargmodes'] is not None and \
+                'v' in r_set['rows'][0]['proargmodes']:
+            ret_status = False
+            msg = gettext(
+                "An 'edbspl' target with a variadic argument is not supported"
+                " and cannot be debugged."
+            )
         else:
             # If user is super user then we should check debugger library is loaded or not
             if user['is_superuser']:

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Tue, 6 Jun 2017 12:59:05 +0100

Thanks, patch applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company