Subject: [pgAdmin4][PATCH] Consolidating gray colors in the application

From: Shruti B Iyer <[email-masked]>
Date: Mon, 05 Jun 2017 15:52:46 +0000

Hi Hackers

Attached are two patches for styling improvements.
1-add-style-guide.patch contains the initial css from the style guide. As
we make further style changes, this file will be updated.
2-change-grays.patch changes the gray color elements in the app to the ones
in the new style guide.

Thanks,
Shruti and Matt

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Wed, 7 Jun 2017 13:58:59 +0100

Thanks, applied. I removed the doc comments from the CSS for now as we
don't have minimisation for that yet (and one of them seemed to be
garbage).

On Mon, Jun 5, 2017 at 4:52 PM, Shruti B Iyer <[email-masked]> wrote:
> 1-add-style-guide.patch contains the initial css from the style guide. As we
> make further style changes, this file will be updated.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 7 Jun 2017 18:52:17 +0530

Hi

With the latest pull, I found:
The header color of Properties panel disappears and background color of
footer area in Edit Properties panel is changed.

---

From: Dave Page <[email-masked]>
Date: Wed, 7 Jun 2017 14:24:57 +0100

> footer area in Edit Properties panel is changed.

Oh, I missed that :-(. Can you come up with a quick fix using the new classes?

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 7 Jun 2017 18:58:33 +0530

Sure I will send.

---

From: Robert Eckhardt <[email-masked]>
Date: Wed, 7 Jun 2017 09:29:47 -0400

Thank you.

-- Rob

---

From: Surinder Kumar <[email-masked]>
Date: Wed, 7 Jun 2017 20:18:18 +0530

Hi

I have used classes 'bg-gray-2 border-gray-3' for styling header and footer
of properties panel which are also used in other places.

Please find attached patch.

---

From: Dave Page <[email-masked]>
Date: Wed, 7 Jun 2017 16:31:57 +0100

Thanks, applied.

On Wed, Jun 7, 2017 at 3:48 PM, Surinder Kumar
<[email-masked]> wrote:
>> On Wed, Jun 7, 2017 at 9:28 AM, Surinder Kumar

---

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 8 Jun 2017 10:48:25 +0530

Hello,

I think we could have use some different grey colour shade for SlickGrid
headers from wcDocker panel, It does not look bad but as a end user I'm not
able to differentiate between them now, please refer screenshot attached.

Is this expected with new design style?

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Shirley Wang <[email-masked]>
Date: Thu, 08 Jun 2017 13:28:32 +0000

Hi Murtuza,

This was before we had checkboxes removed and added column and row
highlighting. Try looking at this now with the query results grid updates
and let me know what you think.

On Thu, Jun 8, 2017 at 1:19 AM Murtuza Zabuawala <
[email-masked]> wrote:

>> >>>> > The header color of Properties panel disappears and background
>> color
>> >>>> > of

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 9 Jun 2017 10:29:13 +0530

Hi Shirley,

The new UI looks awesome :)

On Thu, Jun 8, 2017 at 6:58 PM, Shirley Wang <[email-masked]> wrote:

> On Thu, Jun 8, 2017 at 1:19 AM Murtuza Zabuawala <murtuza.zabuawala@
> enterprisedb.com> wrote:
>
>> Hello,
>>
>>> >>>> Oh, I missed that :-(. Can you come up with a quick fix using the
>>> new
>>> >>>> classes?
>>> >>>>
>>> >>>> --
>>> >>>> Dave Page