Subject: Style guide live website - looking for feedback

From: Shirley Wang <[email-masked]>
Date: Wed, 31 May 2017 18:39:19 +0000

Hi all,

We've started compiling some of the agreed upon styles into a site that is
accessible for all developers.

Link to the site: http://pgadmin4-styleguide.cfapps.io/index.html

As of now, we have colors, type, and alerts documented. Other styles will
be added and where the style guide lives will change sometime in the future.

I'm currently looking for feedback on a few things:
1. how it's structured - does the navigation make sense?
2. the info provided on each page - are you as a developer able to find the
info you need? is there anything missing?
3. usage - what will make this easier for you to use?

Thanks!

Here's the thread for style guide conversation:
https://www.postgresql.org/message-id/flat/CAPG3WN4-KTS0p6rRPxpXNqY8az%2BSw8NQHfjx%2BRFYc8ZqB_00TQ%40ma[email-masked]

---

From: Dave Page <[email-masked]>
Date: Mon, 5 Jun 2017 16:20:56 +0100

On Wed, May 31, 2017 at 7:39 PM, Shirley Wang <[email-masked]> wrote:
> As of now, we have colors, type, and alerts documented. Other styles will be
> added and where the style guide lives will change sometime in the future.
>

Looks good. A couple of thoughts:

- Please use "pgAdmin 4" consistently :-)

- The neutral message panel has a border that is quite visible, whilst
the others have much more subtle borders. Seems like something to fix.

- I think we need some notes on when the different font sizes should be used.

- You've obviously created classes for these styles (e.g. text-14).
Let's make sure they are all actually defined in the stylesheets for
the app before we add the style guide :-)

Thanks!

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Shirley Wang <[email-masked]>
Date: Thu, 08 Jun 2017 14:41:57 +0000

> Just to clarify - is there always a space between pgAdmin and 4? or is it
pgAdmin4?

> the others have much more subtle borders. Seems like something to fix.

It is an interesting contrast. I think it should be changed too.

> Ok. I can start documenting where these fonts are used now, and then we
can think about if that's how we actually want to use them.

> Will do.

---

From: Dave Page <[email-masked]>
Date: Thu, 8 Jun 2017 16:12:13 +0100

> Just to clarify - is there always a space between pgAdmin and 4? or is it

In natural language text, it's always with a space. The number should
be a numeric (not Roman numerals), and only the A should be
capitalised.

In code etc. the space and capitalisation can be dropped if needed.

> Ok. I can start documenting where these fonts are used now, and then we can
> think about if that's how we actually want to use them.
>
>>

Thanks!