Subject: pgAdmin 4 feedback

From: Michael Hornick <[email-masked]>
Date: Mon, 11 Jul 2016 20:18:58 +0000

Hello team - great work!

We have been using Postrgres as the main database for our insurance product for over 10 years, and it has been a great experience so far.  Personally, I have been using a product called AQT to do most of my Postgres SQL work - mainly because of the lack of "features" offered in pgAdmin III.  Although, most developers in our company indeed use pgAdmin III.  Thankfully, it seems that some great headway is now being made.  Let me know if you want a list of features that I use daily on AQT that I would like to see in pgAdmin - I would be happy to list and explain those in order of usefulness.

Issues:

My first issue with the new pgAdmin 4 is that the numeric fields seem to add commas and ".00" in the table listings.  I would need a way to turn this feature off before I could use pgAdmin 4.  The reason is that we use numeric 19,0 often as a record object ID in many fields within our over 700 database tables.  These fields always contain 19 digits, and it seems impossible to easily read these fields using this new listing format.

I have no idea how many testers are providing feedback.  So, please let me know if having another user providing feedback is useful or not.  If not, I will wait until the final release and take a look then.

Thanks.

Mike

.................................

Michael Hornick

Architect | Insurance Systems Inc.<http://www.insurancesystems.com/>

<http://insurancesystems.com/>

T: (416) 249-2260  | 1-877-777-2231 Ext. 319

M: (416) 704-9250

E:   [email-masked]<mailto:[email-masked]>
Skype: [email-masked]

__________________________________________________

This e-mail is intended for the person(s) to whom it is addressed and may contain information which is PRIVILEGED or CONFIDENTIAL. Any unauthorized use, distribution, copying or disclosure by any person other than the addressee(s) is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by return mail and delete the message and any attachments from your system.

---

From: Dave Page <[email-masked]>
Date: Tue, 12 Jul 2016 12:15:28 +0100

Hi

On Mon, Jul 11, 2016 at 9:18 PM, Michael Hornick <
[email-masked]> wrote:

> Hello team – great work!

Thanks!

> We have been using Postrgres as the main database for our insurance
> product for over 10 years, and it has been a great experience so far.
> Personally, I have been using a product called AQT to do most of my
> Postgres SQL work – mainly because of the lack of “features” offered in
> pgAdmin III.  Although, most developers in our company indeed use pgAdmin
> III.  Thankfully, it seems that some great headway is now being made.  Let
> me know if you want a list of features that I use daily on AQT that I would
> like to see in pgAdmin – I would be happy to list and explain those in
> order of usefulness.
>

Please do - you can log feature requests (and bugs) here:
https://redmine.postgresql.org/projects/pgadmin4/issues/new. Please use one
ticket per request/bug.

>
>
> *Issues:*
>
>
>
> My first issue with the new pgAdmin 4 is that the numeric fields seem to
> add commas and “.00” in the table listings.  I would need a way to turn
> this feature off before I could use pgAdmin 4.  The reason is that we use
> numeric 19,0 often as a record object ID in many fields within our over 700
> database tables.  These fields always contain 19 digits, and it seems
> impossible to easily read these fields using this new listing format.
>

Yes, I've had other complaints about that, and am inclined to just disable
numeric formatting as we did in pgAdmin 3.

>
>
>
>
> I have no idea how many testers are providing feedback.  So, please let me
> know if having another user providing feedback is useful or not.  If not, I
> will wait until the final release and take a look then.
>
>
>
> Thanks.
>
>
>
> Mike
>
>
>
> ……………………………
>
> *Michael Hornick *
>
> *Architect* | Insurance Systems Inc. <http://www.insurancesystems.com/>
>
>
>
> *T*: (416) 249-2260  *| *1-877-777-2231 Ext. 319
>
> *M*: (416) 704-9250
>
> *E:  * [email-masked]
>
> *Skype*: [email-masked]
>
> This e-mail is intended for the person(s) to whom it is addressed and may
> contain information which is PRIVILEGED or CONFIDENTIAL. Any unauthorized
> use, distribution, copying or disclosure by any person other than the
> addressee(s) is strictly prohibited. If you have received this e-mail in
> error, please notify the sender immediately by return mail and delete the
> message and any attachments from your system.
>
>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company