Subject: [pgAdmin4][Patch]: RM1739 - Don't show Upload File icon unless it is not in capabilities [Storage Manager]

From: Surinder Kumar <[email-masked]>
Date: Fri, 7 Oct 2016 11:33:26 +0530

Hi,

*Issue:*
When clicked on upload icon while saving a file prompt user to leave page.
It is because the icon is a button and its type is set to submit which
makes it to prompt, instead it should be 'button'

Storage Manager's menu items depends on capabilities list set by the module
using it. If capabilities doesn't have 'upload' in it, It won't work.
Upload button is bound to click event only when it is in capabilities.

*Solution:*
As upload button is being added only when it is in capabilities, so upload
button html is removed from html file. It will not shown on UI untill it is
in capabilities list.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Fri, 7 Oct 2016 12:31:48 +0100

Thanks, patch applied.

On Fri, Oct 7, 2016 at 7:03 AM, Surinder Kumar
<[email-masked]> wrote:
> Issue:
> It is because the icon is a button and its type is set to submit which makes
> it to prompt, instead it should be 'button'
>
> using it. If capabilities doesn't have 'upload' in it, It won't work. Upload
> button is bound to click event only when it is in capabilities.
>
> Solution:

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company