Subject: [pgAdmin][RM4006] Trigger enable always/replica shown as disabled

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 31 Oct 2019 13:21:44 +0530

Hi Hackers,

Attached is the patch for Bug-cum-feature to show always/replica options
for triggers.
The "Trigger enabled" switch control is changed to select2 dropdown now,
with four options as Enable, Enable Replica, Enable Always, Disable.
Changes are done for both triggers and compound triggers(EPAS v12+). The
context menu options of Enable/Disable trigger will work as before.
Docs are updated and test cases are updated accordingly.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Fri, 1 Nov 2019 11:49:28 +0000

Thanks, applied.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company