Subject: [Patch][pgAdmin4]: RM1519 - Error running VACUUM FULL FREEZE ANALYZE VERBOSE

From: Surinder Kumar <[email-masked]>
Date: Thu, 4 Aug 2016 15:29:28 +0530

Hi

This issue is reproduced to me with following steps.:
1) When the query "VACUUM FULL FREEZE ANALYZE VERBOSE" is run for first
time, it runs without error.
2) then the query "SELECT 1" is executed. no error.
3) But when query in step #1 is run again, it throws an error:
*TypeError: cannot concatenate 'str' and 'NoneType' objects*

4) Now executing query in step #2 throws following error:
*Error Message:execute cannot be used while an asynchronous query is
underway********** Error ***********

*Reason:*
When the query in step #1 is run for second time as in step #3, it fails
due to python error thus loading spinner stops and run query button is
enabled. but the query is still running in background.

then on running query in step #4 throws error with message "asynchronous
query is underway" because last run query is not yet finished.

*Solution:*
This is due to python error.
String type and NoneType is now formatted properly which resolves the issue.

Please find attached patch and review.

Thanks,
Surinder Kumar

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Thu, 4 Aug 2016 12:14:12 +0100

Thanks, applied.

On Thu, Aug 4, 2016 at 10:59 AM, Surinder Kumar
<[email-masked]> wrote:
> TypeError: cannot concatenate 'str' and 'NoneType' objects
>
> Error Message:execute cannot be used while an asynchronous query is
> underway********** Error **********
>
> Reason:
> When the query in step #1 is run for second time as in step #3, it fails due
> to python error thus loading spinner stops and run query button is enabled.
> but the query is still running in background.
>
> Solution:

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company