Subject: [pgAdmin4][Patch]: RM #2963 - Backup database, Restore database and Maintenance Database failed for é object.

From: Khushboo Vashi <[email-masked]>
Date: Mon, 25 Dec 2017 16:33:53 +0530

Hi,

Please find the attached patch to fix RM #2963: Backup database, Restore
database and Maintenance Database failed for é object.

Thanks,
Khushboo
diff --git a/web/pgadmin/misc/bgprocess/processes.py b/web/pgadmin/misc/bgprocess/processes.py
index 209c2a1..a5d2655 100644
--- a/web/pgadmin/misc/bgprocess/processes.py
+++ b/web/pgadmin/misc/bgprocess/processes.py
@@ -164,12 +164,13 @@ class BatchProcess(object):
             csv_writer.writerow(_args)
 
         args_val = args_csv_io.getvalue().strip(str('\r\n'))
+        desc_str = dumps(self.desc)
 
         j = Process(
             pid=int(id), command=_cmd,
-            arguments=args_val.decode('utf-8', 'replace') if IS_PY2 and hasattr(args_val, 'decode') \
-                else args_val,
-            logdir=log_dir, desc=dumps(self.desc), user_id=current_user.id
+            arguments=args_val.decode('utf-8', 'replace') if IS_PY2 and hasattr(args_val, 'decode') else args_val,
+            logdir=log_dir, desc=desc_str.decode('utf-8', 'replace') if IS_PY2 and hasattr(desc_str, 'decode')
+            else desc_str, user_id=current_user.id
         )
         db.session.add(j)
         db.session.commit()

---

From: Dave Page <[email-masked]>
Date: Wed, 3 Jan 2018 15:24:40 +0000

Hi

> database and Maintenance Database failed for é object.

With the patch applied, I get:

2018-01-03 15:23:00,110: INFO pgadmin: Executing the process executor with
the arguments: ['/Users/dpage/.virtualenvs/pgadmin4/bin/python',
'/Users/dpage/git/pgadmin4/web/pgadmin/misc/bgprocess/process_executor.py',
'/usr/local/pgsql/bin/pg_dump', u'--file', u'/Users/dpage/e.sql',
u'--host', u'localhost', u'--port', '5432', u'--username', u'postgres',
u'--no-password', u'--verbose', u'--format=c', u'--blobs', u'\xe9']
2018-01-03 15:23:00,117: INFO werkzeug: 127.0.0.1 - - [03/Jan/2018
15:23:00] "POST /backup/job/1/object HTTP/1.1" 200 -
Exception in thread Thread-6:
Traceback (most recent call last):
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py",
line 810, in __bootstrap_inner
    self.run()
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py",
line 763, in run
    self.__target(*self.__args, **self.__kwargs)
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
line 602, in process_request_thread
    self.handle_error(request, client_address)
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
line 599, in process_request_thread
    self.finish_request(request, client_address)
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
line 334, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
line 655, in __init__
    self.handle()
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
line 200, in handle
    rv = BaseHTTPRequestHandler.handle(self)
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/BaseHTTPServer.py",
line 340, in handle
    self.handle_one_request()
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
line 235, in handle_one_request
    return self.run_wsgi()
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
line 177, in run_wsgi
    execute(self.server.app)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
line 165, in execute
    application_iter = app(environ, start_response)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 2000, in __call__
    return self.wsgi_app(environ, start_response)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1991, in wsgi_app
    response = self.make_response(self.handle_exception(e))
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1567, in handle_exception
    reraise(exc_type, exc_value, tb)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1988, in wsgi_app
    response = self.full_dispatch_request()
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1641, in full_dispatch_request
    rv = self.handle_user_exception(e)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1544, in handle_user_exception
    reraise(exc_type, exc_value, tb)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1639, in full_dispatch_request
    rv = self.dispatch_request()
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
line 1625, in dispatch_request
    return self.view_functions[rule.endpoint](**req.view_args)
  File
"/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask_login.py",
line 792, in decorated_view
    return func(*args, **kwargs)
  File "/Users/dpage/git/pgadmin4/web/pgadmin/misc/bgprocess/__init__.py",
line 62, in index
    return make_response(response=BatchProcess.list())
  File "/Users/dpage/git/pgadmin4/web/pgadmin/misc/bgprocess/processes.py",
line 512, in list
    desc = loads(p.desc)
  File
"/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py",
line 1381, in loads
    file = StringIO(str)
UnicodeEncodeError: 'ascii' codec can't encode character u'\ufffd' in
position 138: ordinal not in range(128)

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 10 Jan 2018 12:29:13 +0530

On Wed, Jan 3, 2018 at 8:54 PM, Dave Page <[email-masked]> wrote:

> 2018-01-03 15:23:00,110: INFO pgadmin: Executing the process executor
> with the arguments: ['/Users/dpage/.virtualenvs/pgadmin4/bin/python',
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py",
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py",
> line 763, in run
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/
> lib/python2.7/SocketServer.py", line 602, in process_request_thread
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/
> lib/python2.7/SocketServer.py", line 599, in process_request_thread
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/
> lib/python2.7/SocketServer.py", line 334, in finish_request
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/
> lib/python2.7/SocketServer.py", line 655, in __init__
>     self.handle()
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
> line 200, in handle
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/
> lib/python2.7/BaseHTTPServer.py", line 340, in handle
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
> line 177, in run_wsgi
>     execute(self.server.app)
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/werkzeug/serving.py",
> line 165, in execute
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
> line 2000, in __call__
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
> line 1991, in wsgi_app
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
> line 1988, in wsgi_app
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask/app.py",
>   File "/Users/dpage/.virtualenvs/pgadmin4/lib/python2.7/site-packages/flask_login.py",
>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py",
> line 1381, in loads
>     file = StringIO(str)
> Fixed. Please find the attached updated patch.

index 39bb8e3..3f23a99 100644

         j = Process(
             pid=int(id), command=_cmd,
-            arguments=args_val.decode('utf-8', 'replace') if IS_PY2 and hasattr(args_val, 'decode') \
-                else args_val,
-            logdir=log_dir, desc=dumps(self.desc), user_id=current_user.id
+            arguments=args_val.decode('utf-8', 'replace') if IS_PY2 and hasattr(args_val, 'decode') else args_val,
+            logdir=log_dir, desc=desc_str.decode('utf-8', 'ignore') if IS_PY2 and hasattr(desc_str, 'decode')
+            else desc_str, user_id=current_user.id
         )
         db.session.add(j)
         db.session.commit()
@@ -508,6 +509,7 @@ class BatchProcess(object):
             etime = parser.parse(p.end_time or get_current_time())
 
             execution_time = (etime - stime).total_seconds()
+            p.desc = p.desc.encode('utf-8', 'ignore') if IS_PY2 and hasattr(p.desc, 'decode') else p.desc
             desc = loads(p.desc)
             details = desc

---

From: Dave Page <[email-masked]>
Date: Fri, 12 Jan 2018 09:54:08 +0000

Hi

On Wed, Jan 10, 2018 at 6:59 AM, Khushboo Vashi <
[email-masked]> wrote:

>>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
>>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
>>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
>>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py",
>> line 655, in __init__
>>     self.handle()
>>   File "/System/Library/Frameworks/Python.framework/Versions/2.7/li
>> b/python2.7/BaseHTTPServer.py", line 340, in handle
That's getting further, but still not right. Please see the attached
screenshot - the beginning of the executed command has been lost.

---

From: Khushboo Vashi <[email-masked]>
Date: Fri, 9 Mar 2018 09:24:21 +0530

Hi,

Please find the attached patch to fix below issues:

1. #2963 - Backup database, Restore database and Maintenance Database
failed for é object
2. #3157 - Process viewer doesn't show complete command executed.

Test cases are not included for these fixes as we don't have test cases for
these modules (backup, restore, maintenance).
I will create one separate RM for the same which will cover this.

Thanks,
Khushboo

On Fri, Jan 12, 2018 at 3:24 PM, Dave Page <[email-masked]> wrote:

>>>> Please find the attached patch to fix RM #2963: Backup database,
>>>> Restore database and Maintenance Database failed for é object.
>>>>
>>>
diff --git a/web/pgadmin/misc/bgprocess/processes.py b/web/pgadmin/misc/bgprocess/processes.py
index 02b953d..385b7bd 100644
--- a/web/pgadmin/misc/bgprocess/processes.py
+++ b/web/pgadmin/misc/bgprocess/processes.py
@@ -78,10 +78,20 @@ class BatchProcess(object):
                 _("Could not find a process with the specified ID.")
             )
 
+        try:
+            tmp_desc = loads(p.desc.encode('latin-1')) if \
+                IS_PY2 and hasattr(p.desc, 'encode') else loads(p.desc)
+        except UnicodeDecodeError:
+            tmp_desc = loads(p.desc.encode('utf-8')) if \
+                IS_PY2 and hasattr(p.desc, 'encode') else loads(p.desc)
+        except Exception as e:
+            tmp_desc = loads(p.desc.encode('utf-8', 'ignore')) if \
+                IS_PY2 and hasattr(p.desc, 'encode') else loads(p.desc)
+
         # ID
         self.id = _id
         # Description
-        self.desc = loads(p.desc)
+        self.desc = tmp_desc
         # Status Acknowledged time
         self.atime = p.acknowledge
         # Command
@@ -171,6 +181,16 @@ class BatchProcess(object):
             csv_writer.writerow(_args)
 
         args_val = args_csv_io.getvalue().strip(str('\r\n'))
+        tmp_desc = dumps(self.desc)
+        try:
+            tmp_desc =tmp_desc.decode('utf-8') if\
+                IS_PY2 and hasattr(tmp_desc, 'decode') else tmp_desc
+        except UnicodeDecodeError:
+            tmp_desc = tmp_desc.decode('latin-1') if \
+                IS_PY2 and hasattr(tmp_desc, 'decode') else tmp_desc
+        except Exception:
+            tmp_desc = tmp_desc.decode('utf-8', 'ignore') if \
+                IS_PY2 and hasattr(tmp_desc, 'decode') else tmp_desc
 
         j = Process(
             pid=int(id),
@@ -178,7 +198,7 @@ class BatchProcess(object):
             arguments=args_val.decode('utf-8', 'replace')
             if IS_PY2 and hasattr(args_val, 'decode') else args_val,
             logdir=log_dir,
-            desc=dumps(self.desc),
+            desc=tmp_desc,
             user_id=current_user.id
         )
         db.session.add(j)
@@ -534,7 +554,17 @@ class BatchProcess(object):
             etime = parser.parse(p.end_time or get_current_time())
 
             execution_time = (etime - stime).total_seconds()
-            desc = loads(p.desc)
+            desc = ""
+            try:
+                desc = loads(p.desc.encode('latin-1')) if \
+                    IS_PY2 and hasattr(p.desc, 'encode') else loads(p.desc)
+            except UnicodeDecodeError:
+                desc = loads(p.desc.encode('utf-8')) if \
+                    IS_PY2 and hasattr(p.desc, 'encode') else loads(p.desc)
+            except Exception:
+                desc = loads(p.desc.encode('utf-8', 'ignore')) if \
+                    IS_PY2 and hasattr(p.desc, 'encode') else loads(p.desc)
+
             details = desc
 
             if isinstance(desc, IProcessDesc):
diff --git a/web/pgadmin/misc/bgprocess/static/js/bgprocess.js b/web/pgadmin/misc/bgprocess/static/js/bgprocess.js
index 5e30590..8ad2c65 100644
--- a/web/pgadmin/misc/bgprocess/static/js/bgprocess.js
+++ b/web/pgadmin/misc/bgprocess/static/js/bgprocess.js
@@ -248,7 +248,7 @@ define('misc.bgprocess', [
           if (!self.notifier) {
             var header = $('<div></div>', {
                 class: 'h5 pg-bg-notify-header',
-              }).append($('<span></span>').text(self.desc)),
+              }).append($('<span></span>').text(_.escape(self.desc))),
               content = $('<div class="pg-bg-bgprocess row"></div>').append(
                 header
               ).append(
@@ -366,7 +366,7 @@ define('misc.bgprocess', [
             self.logs[0].scrollTop = self.logs[0].scrollHeight;
           });
           // set bgprocess detailed description
-          $header.find('.bg-detailed-desc').html(self.detailed_desc);
+          $header.find('.bg-detailed-desc').html(_.unescape(self.detailed_desc));
         }
 
         // set bgprocess start time
@@ -562,4 +562,4 @@ define('misc.bgprocess', [
     });
 
   return pgBrowser.BackgroundProcessObsorver;
-});
\ No newline at end of file
+});
diff --git a/web/pgadmin/tools/backup/__init__.py b/web/pgadmin/tools/backup/__init__.py
index 715ff6e..9e70c4f 100644
--- a/web/pgadmin/tools/backup/__init__.py
+++ b/web/pgadmin/tools/backup/__init__.py
@@ -97,11 +97,9 @@ class BackupMessage(IProcessDesc):
 
         def cmdArg(x):
             if x:
-                # x = html.safe_str(x)
                 x = x.replace('\\', '\\\\')
                 x = x.replace('"', '\\"')
                 x = x.replace('""', '\\"')
-
                 return ' "' + x + '"'
             return ''
 
@@ -111,6 +109,7 @@ class BackupMessage(IProcessDesc):
             else:
                 self.cmd += cmdArg(arg)
 
+
     @property
     def message(self):
         # Fetch the server details like hostname, port, roles etc
@@ -189,7 +188,7 @@ class BackupMessage(IProcessDesc):
         res += '</div><div class="h5">'
         res += _("Running command:")
         res += '</b><br><span class="pg-bg-cmd enable-selection">'
-        res += html.safe_str(self.cmd)
+        res += html.safe_str(cmd + self.cmd)
         res += '</span></div>'
 
         return res

---

From: Dave Page <[email-masked]>
Date: Fri, 9 Mar 2018 15:32:53 +0000

Hi

On Fri, Mar 9, 2018 at 3:54 AM, Khushboo Vashi <
[email-masked]> wrote:

> Test cases are not included for these fixes as we don't have test cases
> for these modules (backup, restore, maintenance).

Interesting that you fix these together, as together they also exhibit
another bug :-). Backing up the é database displays the following command:

/usr/local/pgsql/bin/pg_dump --file "/Users/dpage/foo.bak" --host
"localhost" --port "5432" --username "postgres" --no-password --verbose
--format=c --blobs "&#233;"

---

From: Dave Page <[email-masked]>
Date: Fri, 9 Mar 2018 15:39:29 +0000

Hi

> --format=c --blobs "&#233;"

Also, what tests can we add for backup/restore? We have nothing at all at
the moment, and it is pretty troublesome. I'd like to ensure that we can
backup and restore a database correctly, and ensure that the displayed
commands are what we expect and that we get valid output from
pg_dump/pg_restore (though, it may change from PG version to PG version, so
maybe we should just check for something small and generic). I guess this
might need some config parameters for the tests to specify the pg_* utility
paths for each server.

I'd suggest maybe having a feature test that opens the prefs, sets the
appropriate path, then runs a backup, waits for it to finish, checks the
process monitor output, then restores the same backup to a new database,
checking the process monitor output again, and then checking that the
restored database contains at least one object from the original database
(we don't need to check all of pg_dump/pg_restore, just that something
expected was restored). We should use a (partial) database name and backup
filename from the advanced test config file, and I think both should
default to some interesting non-ASCII strings to ensure quoting works.

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 12 Mar 2018 11:30:50 +0530

Hi Dave,

On Fri, Mar 9, 2018 at 9:09 PM, Dave Page <[email-masked]> wrote:

> I can reproduce this issue only with notification dialogue (which I have
fixed in the attached patch) not with the details dialogue. Please refer
the screenshots for the same.

> default to some interesting non-ASCII strings to ensure quoting works.
I was thinking of writing the unit test cases for the processes.py file as
all the major functionalities for backup/restore/maintenance jobs done by
this file, but by this we can not achieve the front-end string validation
esp for non-ASCII strings.
So, I am thinking of writing feature tests (as you have suggested) first
and after that if needed I will write unit test cases.

+        try:

         j = Process(
             pid=int(id),

index 5e30590..0934ae4 100644
+              }).append($('<span></span>').text(_.unescape(self.desc))),

 
         def cmdArg(x):
             if x:
-                # x = html.safe_str(x)

+
     @property
     def message(self):
 
         return res

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Mar 2018 07:45:53 -0400

Hi

> the screenshots for the same.

Huh, interesting. What Python version were you using? I had 2.7.

> and after that if needed I will write unit test cases.

Sounds good. Let's try to keep the feature testing minimal, and expand the
coverage with unit tests.

Thanks!

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 12 Mar 2018 17:17:16 +0530

On Mon, Mar 12, 2018 at 5:15 PM, Dave Page <[email-masked]> wrote:

>>>>> Test cases are not included for these fixes as we don't have test
>>>>> cases for these modules (backup, restore, maintenance).
PY 2.7 and PY 3.5

>> I was thinking of writing the unit test cases for the processes.py file
>> as all the major functionalities for backup/restore/maintenance jobs done
>> by this file, but by this we can not achieve the front-end string
>> validation esp for non-ASCII strings.
> Sure.

---

From: Dave Page <[email-masked]>
Date: Mon, 12 Mar 2018 16:59:45 -0400

So I was trying to test this, and every time I try to run a backup, I'm
getting the following, with or without your patch:

(sqlite3.ProgrammingError) You must not use 8-bit bytestrings unless you
use a text_factory that can interpret 8-bit bytestrings (like text_factory
= str). It is highly recommended that you instead just switch your
application to Unicode strings. [SQL: u'INSERT INTO process (pid, user_id,
command, "desc", arguments, logdir, start_time, end_time, exit_code,
acknowledge) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?)'] [parameters:
(180312205250107339, 1, u'/Library/PostgreSQL/9.4/bin/pg_dump',
'ccopy_reg\n_reconstructor\np0\n(cpgadmin.tools.backup\nBackupMessage\np1\nc__builtin__\nobject\np2\nNtp3\nRp4\n(dp5\nS\'cmd\'\np6\nV
--file "/Users/dpage/foo.dmp" --host "127.0.0.1" --port "5432" --username
"postgres" --no-password --verbose --format=c --blobs
"\xe9"\np7\nsS\'backup_type\'\np8\nI3\nsS\'database\'\np9\nV\xe9\np10\nsS\'bfile\'\np11\nS\'foo.dmp\'\np12\nsS\'sid\'\np13\nI1\nsb.',
u'--file,/Users/dpage/foo.dmp,--host,127.0.0.1,--port,5432,--username,postgres,--no-password,--verbose,--format=c,--blobs,\xe9',
'/var/lib/pgadmin/sessions/process_logs/180312205250107339', None, None,
None, None)]

Any thoughts as to what's going on? I wasn't getting this on my other
laptop, and I can't think what else we would have changed to cause this.

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 13 Mar 2018 08:42:40 +0530

On Tue, Mar 13, 2018 at 2:29 AM, Dave Page <[email-masked]> wrote:

> 'ccopy_reg\n_reconstructor\np0\n(cpgadmin.tools.backup\
> nBackupMessage\np1\nc__builtin__\nobject\np2\nNtp3\nRp4\n(dp5\nS\'cmd\'\np6\nV
> "\xe9"\np7\nsS\'backup_type\'\np8\nI3\nsS\'database\'\np9\
> nV\xe9\np10\nsS\'bfile\'\np11\nS\'foo.dmp\'\np12\nsS\'sid\'\np13\nI1\nsb.',
> u'--file,/Users/dpage/foo.dmp,--host,127.0.0.1,--port,5432,-
> -username,postgres,--no-password,--verbose,--format=c,--blobs,\xe9',
> Deleting all the records from the process table from SQLITE will solve
this problem.
There were few issues related to encoding-decoding in my old patches, you
may have applied those.

>>> Also, what tests can we add for backup/restore? We have nothing at all
>>> at the moment, and it is pretty troublesome. I'd like to ensure that we can

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 00:09:50 -0400

> On 12 Mar 2018, at 23:12, Khushboo Vashi <[email-masked]> wrote:
> 
> 
> 
>> So I was trying to test this, and every time I try to run a backup, I'm getting the following, with or without your patch:
>> 
>> (sqlite3.ProgrammingError) You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings. [SQL: u'INSERT INTO process (pid, user_id, command, "desc", arguments, logdir, start_time, end_time, exit_code, acknowledge) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?)'] [parameters: (180312205250107339, 1, u'/Library/PostgreSQL/9.4/bin/pg_dump', 'ccopy_reg\n_reconstructor\np0\n(cpgadmin.tools.backup\nBackupMessage\np1\nc__builtin__\nobject\np2\nNtp3\nRp4\n(dp5\nS\'cmd\'\np6\nV --file "/Users/dpage/foo.dmp" --host "127.0.0.1" --port "5432" --username "postgres" --no-password --verbose --format=c --blobs "\xe9"\np7\nsS\'backup_type\'\np8\nI3\nsS\'database\'\np9\nV\xe9\np10\nsS\'bfile\'\np11\nS\'foo.dmp\'\np12\nsS\'sid\'\np13\nI1\nsb.', u'--file,/Users/dpage/foo.dmp,--host,127.0.0.1,--port,5432,--username,postgres,--no-password,--verbose,--format=c,--blobs,\xe9', '/var/lib/pgadmin/sessions/process_logs/180312205250107339', None, None, None, None)]
>> 
>> Any thoughts as to what's going on? I wasn't getting this on my other laptop, and I can't think what else we would have changed to cause this.
>> 
> Deleting all the records from the process table from SQLITE will solve this problem.
> There were few issues related to encoding-decoding in my old patches, you may have applied those.

I deleted the database entirely, and still saw the problem.

>>> On Mon, Mar 12, 2018 at 2:00 AM, Khushboo Vashi <[email-masked]> wrote:
>>> 
>>> Hi Dave,
>>> 
>>>>>> On Fri, Mar 9, 2018 at 3:54 AM, Khushboo Vashi <[email-masked]> wrote:
>>>>>> Hi,
>>>>>> 
>>>>>> 1. #2963 - Backup database, Restore database and Maintenance Database failed for é object
>>>>>> Test cases are not included for these fixes as we don't have test cases for these modules (backup, restore, maintenance).
>>>>> Interesting that you fix these together, as together they also exhibit another bug :-). Backing up the é database displays the following command:
>>>>> 
>>>>> /usr/local/pgsql/bin/pg_dump --file "/Users/dpage/foo.bak" --host "localhost" --port "5432" --username "postgres" --no-password --verbose --format=c --blobs "&#233;" 
>>>> 
>>> 
>>> I can reproduce this issue only with notification dialogue (which I have fixed in the attached patch) not with the details dialogue. Please refer the screenshots for the same.
>>>> Also, what tests can we add for backup/restore? We have nothing at all at the moment, and it is pretty troublesome. I'd like to ensure that we can backup and restore a database correctly, and ensure that the displayed commands are what we expect and that we get valid output from pg_dump/pg_restore (though, it may change from PG version to PG version, so maybe we should just check for something small and generic). I guess this might need some config parameters for the tests to specify the pg_* utility paths for each server. 
>>>> 
>>>> I'd suggest maybe having a feature test that opens the prefs, sets the appropriate path, then runs a backup, waits for it to finish, checks the process monitor output, then restores the same backup to a new database, checking the process monitor output again, and then checking that the restored database contains at least one object from the original database (we don't need to check all of pg_dump/pg_restore, just that something expected was restored). We should use a (partial) database name and backup filename from the advanced test config file, and I think both should default to some interesting non-ASCII strings to ensure quoting works.
>>> 
>>> I was thinking of writing the unit test cases for the processes.py file as all the major functionalities for backup/restore/maintenance jobs done by this file, but by this we can not achieve the front-end string validation esp for non-ASCII strings.
>>> So, I am thinking of writing feature tests (as you have suggested) first and after that if needed I will write unit test cases.
>>>> 
>>>> -- 
>>>> Dave Page

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 13 Mar 2018 10:16:36 +0530

On Tue, Mar 13, 2018 at 9:39 AM, Dave Page <[email-masked]> wrote:

>> 'ccopy_reg\n_reconstructor\np0\n(cpgadmin.tools.backup\nBack
>> upMessage\np1\nc__builtin__\nobject\np2\nNtp3\nRp4\n(dp5\nS\'cmd\'\np6\nV
>> "\xe9"\np7\nsS\'backup_type\'\np8\nI3\nsS\'database\'\np9\nV
>> \xe9\np10\nsS\'bfile\'\np11\nS\'foo.dmp\'\np12\nsS\'sid\'\np13\nI1\nsb.',
> I have tried many things to reproduce this but couldn't.  I faced this
issue when I was fixing the issue but not now.
Please make sure to delete the old session and a process table (or
database) and apply my latest patch. (of course you do this :) )
I have PY - 2.7.12, psycopg2 - 2.7.4 and SQLAlhemy -1.0.14 to be more
specific.

>>>> I can reproduce this issue only with notification dialogue (which I
>>> have fixed in the attached patch) not with the details dialogue. Please
>>> refer the screenshots for the same.
>>>

---

From: Dave Page <[email-masked]>
Date: Tue, 13 Mar 2018 16:48:09 -0400

On Tue, Mar 13, 2018 at 12:46 AM, Khushboo Vashi <
[email-masked]> wrote:

>>> '/var/lib/pgadmin/sessions/process_logs/180312205250107339', None,
>>> None, None, None)]
>>>
Well I eventually got this to work (basically recreated most of my dev
environment), so I committed the patch as it's clearly an improvement.

I can still reproduce the display issue I mentioned though - see the
attached screenshot which shows &#233; in a couple of places. I wonder if
it's because the database name is just a single character in my tests,
whilst you had some other unicode characters in the string?

Can you take a look please?

Thanks.

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 14 Mar 2018 08:48:00 +0530

On Wed, Mar 14, 2018 at 2:18 AM, Dave Page <[email-masked]> wrote:

>>>> (sqlite3.ProgrammingError) You must not use 8-bit bytestrings unless
>>>> you use a text_factory that can interpret 8-bit bytestrings (like
>>>> text_factory = str). It is highly recommended that you instead just switch
>>>> your application to Unicode strings. [SQL: u'INSERT INTO process (pid,
>>>> user_id, command, "desc", arguments, logdir, start_time, end_time,
>>>> exit_code, acknowledge) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?)']
>>>> [parameters: (180312205250107339, 1, u'/Library/PostgreSQL/9.4/bin/pg_dump',

> I have tested it with a single character also but couldn't reproduce this.
Please find the attached screen-shot for the same.
Can you please take a complete screen shot of the screen (with left side
tree and properties panel of the database) and send it?

---

From: Dave Page <[email-masked]>
Date: Wed, 14 Mar 2018 17:43:32 -0400

Hi

On Tue, Mar 13, 2018 at 11:18 PM, Khushboo Vashi <
[email-masked]> wrote:

>>>>> So I was trying to test this, and every time I try to run a backup,
>>>>> I'm getting the following, with or without your patch:
>>>>>
>> I have tested it with a single character also but couldn't reproduce
> this. Please find the attached screen-shot for the same.

Sure - attached.

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 15 Mar 2018 17:40:25 +0530

>> tree and properties panel of the database) and send it?
I didn't find any root cause as the below line responsible for un-escaping
the html and it is clearly shown that it is not happening in your case.
$header.find('.bg-detailed-desc').html(_.unescape(self.detailed_desc));

---

From: Dave Page <[email-masked]>
Date: Thu, 15 Mar 2018 15:57:46 -0400

Hi

On Thu, Mar 15, 2018 at 8:10 AM, Khushboo Vashi <
[email-masked]> wrote:

>>>>>>> Any thoughts as to what's going on? I wasn't getting this on my
>>>>>>> other laptop, and I can't think what else we would have changed to cause
>>>>>>> this.
>>>>>>>
>>>>>> I have tried many things to reproduce this but couldn't.  I faced
>>>>> this issue when I was fixing the issue but not now.

Well this is weird - I just tried it again with the dev tools enabled (to
look for console errors), and it worked. Tried again without the dev tools,
and it's still working.

I have no idea what was going on, but it's working now.